Page MenuHomePhabricator

Mass account creation to IP 79.58.14.240 on it.wikiversity
Closed, DeclinedPublic

Description

On it.wikiversity Would a limit of 200 accounts for 24 h it from now until 15.06.2018 23:59:59 UTC For Mass account creation) to School Ip: 79.58.14.240 to allow the registration of a considerable number of the students.

Discussion on the it.wikiversity:
https://it.wikiversity.org/wiki/Wikiversit%C3%A0:Bar#Creazione_di_utenze_dallo_stesso_Ip

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 16 2017, 2:02 PM
Melos added a subscriber: Melos.Sep 16 2017, 4:00 PM

I'm reading the local discussion. I think local Account Creator flag should be enough for the teacher. I don't see any reason to apply this change.

I'm reading the local discussion. I think local Account Creator flag should be enough for the teacher. I don't see any reason to apply this change.

200 accounts in 24h is enormous! It's like a conference like WikiMania. Quoting Melos

The request is to allow students to enrol independently at school. (I do I realise that perhaps 200 is too much, but 25/30?)
The professors can create users but in order to avoid an excessive waste of time in recordings it is better for students to register themselves

CR+1. The problem is that it's weekend. There are no non-emergency deploy during the weekend. Please ALWAYS FILL THIS REQUEST AT LEAST A WEEK BEFORE YOUR EVENT. We CAN'T guarantee your request will be fulfilled otherwise.

Restricted Application added a subscriber: Dereckson. · View Herald TranscriptSep 16 2017, 4:42 PM

No, I disagree this change.
As said previously 200 is enormous. If you are not sure, please at least do a realistic estimation.
Additionally, the end date is in one year, an eternity ! We can't just allow an infinite account creation to a scholar institution IP, it'll be certainly a source of vandalism, and accounts are shared between wikis, so for example Wikipedia will be impacted too.
@Samuele2002 I suppose that you are a teacher that would work on wikiversity with your students during this scholar year. Good news, but as said by @Melos asking for the "account creator" right is the best solution.
See https://meta.wikimedia.org/wiki/Mass_account_creation#Becoming_an_.22account_creator.22. it.wikiversity has this grant Creator di utenze. You can contact locals admins to ask this right. If you can't, ping @MarcoAurelio, he will be able to manually grant you this local right.
Don't hesitate to ask if you have any questions. I keep this task open to track this. Please tell us here when it's done from your side, so this task will be able to be closed.

Framawiki changed the task status from Open to Stalled.Sep 16 2017, 9:25 PM
Framawiki lowered the priority of this task from High to Normal.

@Framawiki There is a misunderstanding I am not a teacher, I am an admin of it. wikiversity are only spokesman for two teachers, however, I will report to the teachers and tell them to use the rights of user creator.
However, I will report to the teachers and tell them to use the rights creator di utenze. I have understood the problems that could lead to limits being raised (I'm not used to making such requests and I don't know their limitations)

@Framawiki There is a misunderstanding I am not a teacher, I am an admin of it. wikiversity are only spokesman for two teachers, however, I will report to the teachers and tell them to use the rights of user creator.
However, I will report to the teachers and tell them to use the rights creator di utenze. I have understood the problems that could lead to limits being raised (I'm not used to making such requests and I don't know their limitations)

Then to abandon change (patch on gerrit)?

Framawiki closed this task as Declined.Sep 20 2017, 8:26 PM

@Framawiki There is a misunderstanding I am not a teacher, I am an admin of it. wikiversity are only spokesman for two teachers, however, I will report to the teachers and tell them to use the rights of user creator.
However, I will report to the teachers and tell them to use the rights creator di utenze. I have understood the problems that could lead to limits being raised (I'm not used to making such requests and I don't know their limitations)

So normally you can grant them the right with your administrator account :) Note too that, as an admin, you already have the same right, so you already can create accounts without limitation. If it could help you one day.

I allow myself to close this task, since it seems you have all the keys in hand. Do not hesitate to reopen this ticket if necessary. @Zoranzoki21 so for me you can close your patch too.

Change 378393 abandoned by Zoranzoki21:
Add new throttle rules..

Reason:
I will close this patch.. If need to be restored, told me.

https://gerrit.wikimedia.org/r/378393