Page MenuHomePhabricator

VisualEditor stuck during the loading process
Closed, InvalidPublic

Description

(I tried to find out which is the closest, already open task, but I didn't find the best one. Please mark as duplicate if it is.)

I use VisualEditor since an early beta stage, and I had several problems which mainly solved during this time.
But I would like to report you that the performance and reliability of the surface is still a problem.

  1. Loading the VisualEditor is very slow for larger pages. Sometimes even for smaller pages. This is very annoying and results an unsatisfied user experience. Sometimes I still use the older editor surface, and there I realized what a big difference if I can edit the page 1-2 seconds after I clicked the edit button instead of waiting 10-20 seconds before.
  1. The loading progress of VisualEditor sometimes just stuck. The progress bar appears, reaches part of it, then stops. Sometimes few minutes later the page appears for editing, sometime this never happens. Usually reloading the page helps, but sometimes not. See a print screen here: https://pasteboard.co/GKEw56L.png

I am sure, it is not easy to solve these problems, but we should improve, because the bad user experience has an effect on the whole reputation of Wikipedia.

Event Timeline

Samat created this task.Sep 16 2017, 4:41 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 16 2017, 4:41 PM
Framawiki added a subscriber: Framawiki.

@Samat: Thanks for reporting this. Did the assignee of this task agree on being the assignee?
Which exact versions of MediaWiki and VisualEditor do yo use? When this happens, can you use the Developer Tools of your browser and go to the "Network" tab to see which parts are slow to load? Which browser do you use?

Samat added a comment.EditedSep 16 2017, 7:35 PM

@Aklapper actually no, he didn't. I assigned to James because he is the product manager of the VisualEditor team, and he will know who is the best person to be assigned to this task.

These phenomena were the same on many Wikimedia wikis for a long time. I created the ticket today after this happened again on Meta-Wiki (see the attached screenshot of the stuck page). You can find the configuration of the wiki here: https://meta.wikimedia.org/wiki/Special:Version

I use mainly Firefox, usually the latest version. Right now that is not true, my version is 53.0.3 (latest is 55.0). I am not familiar how can I debug a problem, but I will check the Network tab next time, if I feel it is really slow or stuck. Now, I tested on two pages and attached screenshots of the results, but the performance sometimes much worse.
On a smaller page: https://pasteboard.co/GKFUFe3.png , https://pasteboard.co/GKG2z0R.png
On a bigger page: https://pasteboard.co/GKFVaJw.png, https://pasteboard.co/GKG2Wjt.png

Aklapper removed Jdforrester-WMF as the assignee of this task.Sep 18 2017, 8:49 AM
Aklapper added a subscriber: Jdforrester-WMF.
Aklapper removed a subscriber: Jdforrester-WMF.

Alright. In that case, please do not assign tasks without consent. Thanks :)

Deskana closed this task as Invalid.Sep 18 2017, 10:02 AM
Deskana added a subscriber: Deskana.

@Aklapper actually no, he didn't. I assigned to James because he is the product manager of the VisualEditor team, and he will know who is the best person to be assigned to this task.

I am the product manager of the Editing team now. As Andre said, you don't need to assign tasks to me, since we subscribe to the projects and can see the tasks just the same anyway.

Loading the VisualEditor is very slow for larger pages. Sometimes even for smaller pages.

This general problem is something the team is aware of. Right now, we have anecdotal evidence that performance can be bad in some cases, like very large pages. This is not sufficient information to understand the problem. For this reason, it's one of the team's goals for Q2 (Oct - Dec 2017) to do a rigorous performance audit and see what things can be changed to improve performance. There are other tasks for this, e.g. T154843.

The loading progress of VisualEditor sometimes just stuck. The progress bar appears, reaches part of it, then stops. Sometimes few minutes later the page appears for editing, sometime this never happens. Usually reloading the page helps, but sometimes not. See a print screen here: https://pasteboard.co/GKEw56L.png

If a few minutes later it's available for editing, then it's the performance issues mentioned above that are the problem, and as I mentioned above we will be working to find out more about those.

If it doesn't eventually load, then you'd need to file a more specific task with more details. The most useful information is the console information, which is a tab in the same section there, which tells us if there was some error with the code. That should be a separate task, not a broad "VisualEditor sometimes gets stuck" task like this. Right now, for me, the example page you gave loads fast and loads flawlessly, so there is nothing can be reproduced at this moment.

So, in summary, the information given in this task is either already covered under other tasks, or is too broad to be actionable, so I am closing this as invalid. Hopefully the directions I've given above are useful for resolving that. :-)

Samat added a comment.EditedSep 19 2017, 9:04 PM

I am the product manager of the Editing team now.

I am sorry, I didn't know. It is not always easy to follow the changes at the WMF :)

As Andre said, you don't need to assign tasks to me, since we subscribe to the projects and can see the tasks just the same anyway.

Didn't know, neither. I am quite new on Phabricator, I am just learning the system. One of your colleagues encouraged me that if I see a problem, the best thing I can do is writing a bug ticket for it, rather then hope than somebody else will do...

Loading the VisualEditor is very slow for larger pages. Sometimes even for smaller pages.

This general problem is something the team is aware of. Right now, we have anecdotal evidence that performance can be bad in some cases, like very large pages. This is not sufficient information to understand the problem. For this reason, it's one of the team's goals for Q2 (Oct - Dec 2017) to do a rigorous performance audit and see what things can be changed to improve performance. There are other tasks for this, e.g. T154843.

I am really happy that the performance improvement is in the team's focus and priorities. I look forward to the results. Thank you for your work.

The loading progress of VisualEditor sometimes just stuck. The progress bar appears, reaches part of it, then stops. Sometimes few minutes later the page appears for editing, sometime this never happens. Usually reloading the page helps, but sometimes not. See a print screen here: https://pasteboard.co/GKEw56L.png

If a few minutes later it's available for editing, then it's the performance issues mentioned above that are the problem, and as I mentioned above we will be working to find out more about those.
If it doesn't eventually load, then you'd need to file a more specific task with more details. The most useful information is the console information, which is a tab in the same section there, which tells us if there was some error with the code. That should be a separate task, not a broad "VisualEditor sometimes gets stuck" task like this. Right now, for me, the example page you gave loads fast and loads flawlessly, so there is nothing can be reproduced at this moment.

I will try to be more specific next time. But first I didn't now what should I check in case of this problem. Second, generally I don't use the browser in "debugging mode", and if the reload of the page helps, I already there, that I have no evidence (only a useless screen shot, like now) :) Anyway, I will try to do better next time :)

So, in summary, the information given in this task is either already covered under other tasks, or is too broad to be actionable, so I am closing this as invalid. Hopefully the directions I've given above are useful for resolving that. :-)

Thank you for your informative response. I really appreciated it.

I am sorry, I didn't know. It is not always easy to follow the changes at the WMF :)

No problem! I have trouble keeping up myself. :-)

Didn't know, neither. I am quite new on Phabricator, I am just learning the system. One of your colleagues encouraged me that if I see a problem, the best thing I can do is writing a bug ticket for it, rather then hope than somebody else will do...

Also no problem! It's always better to file a task and find out it's a duplicate than to not file a task and have an issue go unreported. If in doubt, file a task.

I am really happy that the performance improvement is in the team's focus and priorities. I look forward to the results. Thank you for your work.

:-D

I will try to be more specific next time. But first I didn't now what should I check in case of this problem. Second, generally I don't use the browser in "debugging mode", and if the reload of the page helps, I already there, that I have no evidence (only a useless screen shot, like now) :) Anyway, I will try to do better next time :)
Thank you for your informative response. I really appreciated it.

Thanks to you, too. :-)