Page MenuHomePhabricator

Timeless top bar hides map navigation buttons
Closed, ResolvedPublic

Description

Reported by @Bastenbas

The header bar of Timeless hides map navigation buttons, when a map is shown in a plain-screen.
Sample : https://fr.wikipedia.org/wiki/Pavillon_des_Indes?useskin=timeless#/maplink/0

Event Timeline

Restricted Application added a project: Discovery. · View Herald TranscriptSep 16 2017, 6:37 PM
debt triaged this task as Normal priority.Sep 18 2017, 2:52 PM
debt updated the task description. (Show Details)
debt added a subscriber: debt.

I've added a screenshot of this happening.

The problem is cased by timeless header bar z-index. It can be solved with CSS.

.mw-header-container, .mw-header-hack {
z-index: 1
}

Small correction:

#mw-header-container, #mw-header-hack {
z-index: 1
}

Iniquity reopened this task as Open.Nov 24 2017, 7:25 AM
Iniquity closed this task as a duplicate of T177823: Timeless and Kartographer interactions.
Iniquity added a subscriber: Iniquity.

Sorry, missclick.

TheDJ added a subscriber: TheDJ.Nov 24 2017, 8:46 AM

Unfortunately not that simple. Also has to account for mw-header-nav-hack at some resolutions, which in turn has to account for sidebar navigation elements that are overlayed on top of this, and out of dom order.... This area is a bit messy and probably requires some attention, to make it less fragile.

Also happens for example when editing template and using Template documentation editor dialog - top part (which contains "Done" button) is hidden behind Timeless nav header.

matmarex closed this task as Resolved.Jan 30 2018, 12:12 AM
matmarex claimed this task.
matmarex added a subscriber: matmarex.

This is now resolved with the fix for T183284. All OOUI dialogs display on top of the normal Timeless header.

The fix is not yet deployed to production wikis, but you can verify it on beta: https://en.wikipedia.beta.wmflabs.org/wiki/Map?useskin=timeless#/map/0