jQuery.IME not working in VisualEditor/2017 wikitext editor
Closed, ResolvedPublic8 Story Pointsbug

Description

ULS not working properly for Kannada in Visual editor. It shows the Kannada character and English characcter for every key pressed. We don't get the desired Kannada words.

Steps to Reproduce:

  1. Open http://kn.wikipedia.org
  2. Click on ನನ್ನ ಪ್ರಯೋಗಪುಟ or open your SandBox
  3. Click on ಸಂಪಾದಿಸಿ (invoke Visual Editor)
  4. Select any Kannada keyboard layout from ULS, for ex., KGP/Nudi/KP Rao
  5. Type any word in Kannada, for ex., knfnw

Already tested page http://kn.wikipedia.org/wiki/ಸದಸ್ಯ:Pavanaja/ನನ್ನ_ಪ್ರಯೋಗಪುಟ
Actual Results:
The result is ಕkನnfನnಡw.

Expected Results:
But it should have been ಕನ್ನಡ

The same issue is also reported for Telugu Wikipedia.

Pavanaja created this task.Sep 18 2017, 4:48 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 18 2017, 4:48 AM
Anooprao updated the task description. (Show Details)Sep 18 2017, 11:28 AM
Aklapper updated the task description. (Show Details)Sep 19 2017, 3:31 PM

I can't set the priority of this task due to a bug.

@dchan Can you take a look at this please? The impact may be severe, but I don't know enough this to know that myself.

I also can't set the story points of this task due to a bug. Cool.

Elitre added a subscriber: Elitre.Wed, Sep 20, 1:43 PM

It is probably severe, because it's also reported for Telugu.

Elitre updated the task description. (Show Details)Wed, Sep 20, 1:44 PM

Hindi language also same issue

It is probably severe, because it's also reported for Telugu.

I think the problem is there for all Indic Wikis. I checked with Tulu (it uses Kannada IME, hence it has to be there), Telugu and Malayalam. For every key pressed, it displays the English character and the Indic character.

Elitre renamed this task from ULS not working properly for Kannada in Visual editor to ULS not working properly for Indic wikis in Visual editor.Wed, Sep 20, 1:55 PM

This seems happening in 2017 wikitext editor too.

Arrbee added a subscriber: Arrbee.Tue, Oct 3, 5:54 AM
Elitre renamed this task from ULS not working properly for Indic wikis in Visual editor to ULS not working properly for Indic wikis in visual editor/2017 wikitext editor.Tue, Oct 3, 7:27 AM
Arrbee added a comment.Tue, Oct 3, 4:17 PM

ULS not working properly for Kannada in Visual editor. It shows the Kannada character and English characcter for every key pressed. We don't get the desired Kannada words.

A quick note that not all of ULS is broken, but specifically input methods. Language and font selection seem to be ok.

Catrope triaged this task as Unbreak Now! priority.Tue, Oct 3, 5:44 PM
Restricted Application added subscribers: Liuxinyu970226, Jay8g, TerraCodes. · View Herald TranscriptTue, Oct 3, 5:44 PM

Is this a regression? Do we know when it was last working as that will help us pin down the problem?

Pinging @dchan

Anooprao added a comment.EditedTue, Oct 3, 5:50 PM

I first observed ULS malfunction on sept 16 or 15, before that it was working fine

Jdforrester-WMF set the point value for this task to 8.
dchan renamed this task from ULS not working properly for Indic wikis in visual editor/2017 wikitext editor to jQuery.IME not working in VisualEditor/2017 wikitext editor.Sat, Oct 7, 12:14 PM
dchan added a comment.Sat, Oct 7, 12:21 PM

This was introduced in 37d0c27478983c9607cd85fdc6551b16a9bbb3a5 - an exception is thrown whenever jQuery.IME attempts to do any text replacement, and the timing of the exception means that the document ends up with both the substitution and the typed character text.

It happens because ve.ce.Surface#onDocumentInput uses event.originalEvent.inputType, but jQuery.IME creates synthetic events with $element.trigger( 'input' ) whose originalEvent is undefined.

Change 382971 had a related patch set uploaded (by Divec; owner: Divec):
[VisualEditor/VisualEditor@master] Don't assume events have an originalEvent object

https://gerrit.wikimedia.org/r/382971

Change 382971 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] Don't assume events have an originalEvent object

https://gerrit.wikimedia.org/r/382971

Change 383253 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (c5c5123)

https://gerrit.wikimedia.org/r/383253

Change 383253 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (c5c5123)

https://gerrit.wikimedia.org/r/383253

Deskana closed this task as Resolved.Tue, Oct 10, 3:25 PM

Should now be fixed in master.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptTue, Oct 10, 3:25 PM

@Deskana This should be deploy to Production and tested.

@Deskana Still facing same issue, not solved yet

@Deskana This should be deploy to Production and tested.

The fixes were tested by @Jdforrester-WMF, and will also soon be tested by @Ryasmeen. They will be automatically deployed over the next two days.

@Deskana Still facing same issue, not solved yet

The fixes are now in the code base, but not live on the site yet. As mentioned above, they will be deployed in two days.

@Deskana fix is live now, thanks for resolving.

@Anooprao Glad it's working. :-)