Page MenuHomePhabricator

Regression: Old interface appearing alongside New Filters on Watchlist (on Beta)
Closed, ResolvedPublic

Description

See the screenshot below. The old interface is appearing below the new one. Also, I'm not seeing Live Update on this page.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 18 2017, 4:29 PM
jmatazzoni triaged this task as Unbreak Now! priority.Sep 18 2017, 4:30 PM
Restricted Application added subscribers: Liuxinyu970226, Jay8g, TerraCodes. · View Herald TranscriptSep 18 2017, 4:30 PM
SBisson lowered the priority of this task from Unbreak Now! to Normal.Sep 18 2017, 6:48 PM

The faulty patch (https://gerrit.wikimedia.org/r/#/c/378388/) has been reverted but I'm still going to fix Watchlist so that the next attempt at making Xml::fieldset() always balanced won't break it.

Change 378767 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/core@master] WLFilter: always create a balanced fieldset

https://gerrit.wikimedia.org/r/378767

Change 378767 merged by jenkins-bot:
[mediawiki/core@master] WLFilters: always create a balanced fieldset

https://gerrit.wikimedia.org/r/378767

Checked in betalabs - the issue is resolved.

Etonkovidova closed this task as Resolved.Sep 19 2017, 6:35 PM