Page MenuHomePhabricator

ContentTranslation on Hebrew Wiki crashes on Chrome for a page with multiple templates
Closed, ResolvedPublic

Description

This comes from Facebook and Hebrew Wiki. A user is complaining that ContentTranslation has crashed and they can't edit anymore.

Details from the user:

Console error:

(anonymous) @ VM4235:328

VM4235:339 This page is using the deprecated ResourceLoader module "jquery.ui.widget".

(anonymous) @ VM4235:339

VM4235:389 This page is using the deprecated ResourceLoader module "jquery.tipsy".

mw.loader.implement.css @ VM4235:389

VM4235:323 This page is using the deprecated ResourceLoader module "jquery.ui.core".

Please use "mediawiki.ui.button" or "oojs-ui" instead.

mw.loader.implement.css @ VM4235:323

VM4248:91 Uncaught TypeError: Cannot read property 'prop' of undefined

    at TemplateTool.replaceTargetTemplate (eval at <anonymous> (<nowiki>https://he.wikipedia.org/w/load.php?debug=false&lang=he&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=0ynbgde:4:681</nowiki>), <anonymous>:91:147)

    at TemplateTool.markUndaptable (eval at <anonymous> (<nowiki>https://he.wikipedia.org/w/load.php?debug=false&lang=he&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=0ynbgde:4:681</nowiki>), <anonymous>:92:864)

    at Object.eval (eval at <anonymous> (<nowiki>https://he.wikipedia.org/w/load.php?debug=false&lang=he&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=0ynbgde:4:681</nowiki>), <anonymous>:94:498)

    at Object.<anonymous> (<nowiki>https://he.wikipedia.org/w/load.php?debug=false&lang=he&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=0ynbgde:47:129</nowiki>)

    at fire (<nowiki>https://he.wikipedia.org/w/load.php?debug=false&lang=he&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=0ynbgde:45:122</nowiki>)

    at Object.fireWith [as rejectWith] (<nowiki>https://he.wikipedia.org/w/load.php?debug=false&lang=he&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=0ynbgde:46:431</nowiki>)

    at Object.<anonymous> (<nowiki>https://he.wikipedia.org/w/load.php?debug=false&lang=he&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=0ynbgde:47:322</nowiki>)

    at fire (<nowiki>https://he.wikipedia.org/w/load.php?debug=false&lang=he&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=0ynbgde:45:122</nowiki>)

    at Object.fireWith [as rejectWith] (<nowiki>https://he.wikipedia.org/w/load.php?debug=false&lang=he&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=0ynbgde:46:431</nowiki>)

    at Object.deferred.(anonymous function) (<nowiki>https://he.wikipedia.org/w/load.php?debug=false&lang=he&modules=jquery%2Cmediawiki%7Cmediawiki.legacy.wikibits&only=scripts&skin=vector&version=0ynbgde:47:790</nowiki>)

Event Timeline

Mooeypoo created this task.Sep 19 2017, 5:29 PM
Restricted Application added subscribers: jeblad, Aklapper. · View Herald TranscriptSep 19 2017, 5:29 PM
Arrbee assigned this task to santhosh.Oct 27 2017, 6:07 AM
Arrbee triaged this task as Normal priority.
Arrbee raised the priority of this task from Normal to Needs Triage.
Arrbee triaged this task as Normal priority.
Arrbee added a project: Language-2017-Oct-Dec.
Arrbee moved this task from Needs Triage to Oct-Dec 2017 on the ContentTranslation board.

euh, I'm not a ContentTranslation developer (but I spam them with my reports). As far I can see both error logs are different, so it's difficult to know.

My attempts to reproduce this is failed. I tried the translation of en:The Phantom Tollbooth to he and ca languages using Chrome and Firefox. If any of you were able to reproduce, please give the langauge pair title details. Also the template if any caused the issue.

Meanwhile I will try to do some defence against the js error shown above from happening.

Change 393556 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@master] Prevent js error in template adaptation

https://gerrit.wikimedia.org/r/393556

Change 393556 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Prevent js error in template adaptation

https://gerrit.wikimedia.org/r/393556

Nikerabbit moved this task from Backlog to QA on the Language-2017-Oct-Dec board.Nov 27 2017, 4:11 PM
Nikerabbit removed a project: Patch-For-Review.

Checked in hewiki (wmf.10) - there are still plenty of [CX] Error in adapting template. missing data-mw that seem to be triggered on nested templates, e.g.

{{quote box | align = right | width = 25em | salign = right
| quote =  "Oh dear, all those words again," thought Milo as he climbed into the wagon with Tock and the cabinet members. "How are you going to make it move? It doesn't have a—"<br>
"Be very quiet," advised the duke, "for it goes without saying."<br>
And, sure enough, as soon as they were all quite still, it began to move through the streets, and in a very short time they arrived at the royal palace.
| source = ''The Phantom Tollbooth'' (in Dictionopolis) {{sfn|Juster and Marcus|p=79}}}}

But ContentTranslation does not crash (I did not try to publish it though).

As for the scope of the issue,

ContentTranslation has crashed and they can't edit anymore

the issue is resolved. "Error in adapting template..." is a know error and will be addressed in different phab tasks.

Etonkovidova closed this task as Resolved.Nov 30 2017, 6:48 PM
Nikerabbit moved this task from QA to Done on the Language-2017-Oct-Dec board.Dec 1 2017, 8:30 AM