Page MenuHomePhabricator

Block images lose captions when moved
Closed, ResolvedPublic1 Story Points

Description

Looks like another TreeModifier regression, the image node is getting constructed before the children have been populated, so the CE node thinks it shouldn't render a caption.

Event Timeline

Esanders created this task.Sep 19 2017, 8:58 PM
Restricted Application added a project: VisualEditor. · View Herald TranscriptSep 19 2017, 8:58 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Esanders triaged this task as Unbreak Now! priority.Sep 19 2017, 8:58 PM
Restricted Application added subscribers: Liuxinyu970226, Jay8g, TerraCodes. · View Herald TranscriptSep 19 2017, 8:58 PM

Change 379053 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/VisualEditor@master] Wait for tree to finish building before updating caption

https://gerrit.wikimedia.org/r/379053

The above patch fixes symptom but not the cause. Pinging @dchan

DLynch added a subscriber: DLynch.Sep 20 2017, 3:34 PM

Change 379053 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Wait for tree to finish building before updating caption

https://gerrit.wikimedia.org/r/379053

greg lowered the priority of this task from Unbreak Now! to High.Sep 25 2017, 11:28 PM
greg added a subscriber: greg.

The above patch fixes symptom but not the cause. Pinging @dchan

Still UBN! with the symptom fix? Doesn't appear to be so, thus lowering.

Deskana set the point value for this task to 1.Oct 17 2017, 5:16 PM
Deskana removed a project: Patch-For-Review.
Deskana lowered the priority of this task from High to Low.Aug 27 2018, 1:24 PM
Deskana moved this task from To Triage to Freezer on the VisualEditor board.
matmarex closed this task as Resolved.Nov 2 2018, 1:40 PM
matmarex added a subscriber: matmarex.

Ed's workaround was removed in rEVED26e7728272e2: ve.ce.MWBlockImageNode: Allow normal CE rendering to handle the caption. I think we can consider this properly fixed.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptNov 2 2018, 1:40 PM