Page MenuHomePhabricator

Mentions not displaying properly when replying in flow
Closed, ResolvedPublic

Description

Trying to reply to a comment in a flow discussion, adding a mention showed the name of the template in red instead of showing the user I was mentioning.

The expected behaviour would be to shoe the name of the user instead.

Event Timeline

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptSep 20 2017, 8:50 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Elitre added a subscriber: Elitre.Sep 20 2017, 3:27 PM
SBisson added a subscriber: SBisson.EditedSep 20 2017, 4:26 PM

Caused by https://gerrit.wikimedia.org/r/#/c/377875

EDIT: Just to add some context (because that link alone is not very helpful), in the process of renaming Flow to Structured Discussions, the message specifying the Flow ping template name (flow-ve-mention-template-title) was reworded from "FlowMention" to "Structured DiscussionsMention", and then translated accordingly in several languages. The consequence is the name of the template in the message and the name of the actual template on wiki don't match.

The issue is currently present in wmf.19 (testwiki, mediawiki). Entering Mention in wikitext works.

Change 379270 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/Flow@master] Follow-up 02dc3605c6b: don't rename the FlowMention template

https://gerrit.wikimedia.org/r/379270

Change 379270 merged by jenkins-bot:
[mediawiki/extensions/Flow@master] Follow-up 02dc3605c6b: don't rename the FlowMention template

https://gerrit.wikimedia.org/r/379270

Change 379276 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/Flow@master] Follow-up 02dc3605c6b, 7c35b50f0e: also fix bad translations of FlowMention template name

https://gerrit.wikimedia.org/r/379276

Change 379278 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/Flow@wmf/1.30.0-wmf.19] Follow-up 02dc3605c6b: don't rename the FlowMention template

https://gerrit.wikimedia.org/r/379278

Change 379280 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/Flow@wmf/1.30.0-wmf.19] Follow-up 02dc3605c6b, 7c35b50f0e: also fix bad translations of FlowMention template name

https://gerrit.wikimedia.org/r/379280

Change 379276 merged by jenkins-bot:
[mediawiki/extensions/Flow@master] Follow-up 02dc3605c6b, 7c35b50f0e: also fix bad translations of FlowMention template name

https://gerrit.wikimedia.org/r/379276

Change 379278 merged by jenkins-bot:
[mediawiki/extensions/Flow@wmf/1.30.0-wmf.19] Follow-up 02dc3605c6b: don't rename the FlowMention template

https://gerrit.wikimedia.org/r/379278

Change 379280 merged by jenkins-bot:
[mediawiki/extensions/Flow@wmf/1.30.0-wmf.19] Follow-up 02dc3605c6b, 7c35b50f0e: also fix bad translations of FlowMention template name

https://gerrit.wikimedia.org/r/379280

Mentioned in SAL (#wikimedia-operations) [2017-09-20T18:40:46Z] <catrope@tin> Started scap: Patches for T176302, T175962, T173533

Mentioned in SAL (#wikimedia-operations) [2017-09-20T19:02:15Z] <catrope@tin> Finished scap: Patches for T176302, T175962, T173533 (duration: 21m 29s)

Catrope added a subscriber: Catrope.

This should be fixed in production now.

Checked in cawiki (wmf.19) - Mentions with template {{FlowMention|username}} and other mention format are working.

Etonkovidova closed this task as Resolved.Sep 20 2017, 9:27 PM