Page MenuHomePhabricator

Request access to logstash (nda group) for @framawiki
Closed, DeclinedPublic

Description

As a volunteer to many phabricator projects such as Wikimedia-Site-requests and deploying many configuration changes, I would like to have access to logstash to help me in the creation of commits, to understand how certain codes works to better configure them and more generally to complete the error reports I encounter.

I'm very present on the French Wikipedia and in particular I'm available as soon as technical issues are raised. I can't always answer, often request assistance from @Trizek-WMF, but knowing the exact error can allow me to more accurately reassess the problem before creating a phab task.

The only page documentation I've found is https://wikitech.wikimedia.org/wiki/Volunteer_NDA that asks me to create this task, what I'm doing :)

Event Timeline

Restricted Application added a project: Operations. · View Herald TranscriptSep 20 2017, 9:03 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

{{support}} Trusted user, involved in tech support on fr. ~~~~

@Zoranzoki21 This needs to be supported/approved by some people, NDAS, etc. I suggest you un-claim the task so the relevant people knows this task is pending; unless others disagree :)

FWIW I don't oppose @Framawiki being given access to Logstash.

Zoranzoki21 removed Zoranzoki21 as the assignee of this task.Sep 22 2017, 10:15 PM

@Zoranzoki21 This needs to be supported/approved by some people, NDAS, etc. I suggest you un-claim the task so the relevant people knows this task is pending; unless others disagree :)

FWIW I don't oppose @Framawiki being given access to Logstash.

Ok

To better understand your request, could you give a sample of tasks you would like to create with LogStash access?

At what frequency do you bump on an error code on a production wiki?

Did you also try to reproduce the errors on beta.wmflabs.org sites, so it's logged in publicly accessible https://logstash-beta.wmflabs.org?

Dzahn added subscribers: Qgil, Dzahn.EditedSep 26 2017, 8:06 PM

Reading https://wikitech.wikimedia.org/wiki/Volunteer_NDA it seems that

"At least one comment of support from a Wikimedia Foundation employee, explaining why it is a good idea to accept your request" is covered by @Trizek-WMF

and next we now need:

"A comment of approval from one Wikimedia Foundation manager (usually the manager of an employee supporting you)."

Looking at https://wikimediafoundation.org/wiki/Staff_and_contractors it seems @Qgil is the one that would have to support it. Quim, do you support this?

Framawiki added a comment.EditedSep 26 2017, 11:26 PM

To better understand your request, could you give a sample of tasks you would like to create with LogStash access?

I take the example of mediawiki, where I help CX users. ContentTranslation uses JS+a PHP server, so I know that sometimes logstash will be empty for this kind of request.
For example this report : I asked the user to give more information, I left the ticket so that someone with access to logstash could view it but it was left unanswered.
It's the same for a large number of reported errors, see my contributions on mw.org
On the same basis a user complains in French that he often has errors, it is useless to create a phab ticket since it is probably a not important problem. But it doesn't cost me anything to see if I see anything with the indications given.

At what frequency do you bump on an error code on a production wiki?

Very regularly, see my phab account, it is quite full :)

Did you also try to reproduce the errors on beta.wmflabs.org sites, so it's logged in publicly accessible https://logstash-beta.wmflabs.org?

I haven't gotten used to it, but I can't ask others users to replicate their problems on it.

Qgil added a comment.Sep 27 2017, 9:16 AM

Looking at https://wikimediafoundation.org/wiki/Staff_and_contractors it seems @Qgil is the one that would have to support it. Quim, do you support this?

Yes. Our team believes that @Framawiki will make good use of those permissions. Thank you for your contributions! :)

Thanks @Qgil!

It seems all other criteria have been met so we can now move on to the last step "Get sign off by a C-level staff of the Wikimedia Foundation."

@VColeman Hello, we have this request for volunteer access (LDAP group "nda") here. There is support from other people, including WMF employees and also from Quim as the engineering community manager. The docs say after all other criteria have been met we need to get a C-level to sign off and that it is usually you doing that. Would you sign-off on this one? Thanks

(Thanks @Framawiki to have developed the scope of your request. Yes, it shows a real need for the permission requested.)

Approved on my side

Thanks Victoria!

@Framawiki It's going well, you have all the approvals now incl. c-level. Per the workflow steps, I am now contacting Legal to reach out to you so you can sign on Cobblestone.

Thank you @Dzahn for the ping. I can create a customized NDA for Framawiki.

@Framawiki - I need a couple of details for the NDA - your full name, a physical address and email address to route the document to you for electronic signature. Could you email me with that info? rstallman@wikimedia.org

Thank you!

Framawiki claimed this task.Oct 3 2017, 9:12 PM

Thanks @Dzahn for taking care of my request.
I will discuss by email with @RStallman-legalteam about the document.

Peachey88 moved this task from Backlog to Assigned on the WMF-Legal board.Oct 14 2017, 11:33 PM
RobH changed the task status from Open to Stalled.Oct 16 2017, 8:23 PM
RobH moved this task from Backlog to NDA Pending on the LDAP-Access-Requests board.

@Framawiki Any progress on this?

RobH closed this task as Declined.Nov 13 2017, 7:42 PM
RobH added a subscriber: RobH.

This is still pending after over a month without update. I'm going to go ahead and close this task as denied.

If/When an NDA is signed and on file, please feel free to simply reopen this task! Leaving it sit open, my fear is we'll just glance at it, and ignore it otherwise. If it is closed, when it shows up on our ops clinic dashboard again, it'll not have the stalled/overlooked/fatigued status.

Please feel free to simply re-open at the time of NDA submission to WMF legal.