Page MenuHomePhabricator

Stop community links from opening then closing on Recent changes
Closed, ResolvedPublic

Description

When a user who has previously closed her community links (aka "Other review tools", aka Recentchangestext) loads Recent Changes, the community links first flash open, then close, causing the main results area to bounce around and slowing page load (or causing page load to be perceived as slower).

Please make it so that if links panel is meant to be closed, the page just loads with it closed, and if the panel is meant to be open, the page loads with it open.

Event Timeline

Change 379689 had a related patch set uploaded (by Mooeypoo; owner: Mooeypoo):
[mediawiki/core@master] RCFilters: Start the toplinks collapsed/expanded by cookie value

https://gerrit.wikimedia.org/r/379689

Change 379689 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Start the toplinks collapsed/expanded by cookie value

https://gerrit.wikimedia.org/r/379689

Krinkle removed a subscriber: Krinkle.Sep 22 2017, 6:08 PM
Etonkovidova added a subscriber: Etonkovidova.EditedSep 22 2017, 6:59 PM

Checked in betalabs two cases:

(1) The community links were expanded and the page loads. The community links are displayed unchanged while the page is being load.

(2) The community links were collapsed and the page loads. The community links is not displayed during the page load.

@jmatazzoni - you can take a look in betalabs how RC page loads the page without uncollapsing the community links.

Etonkovidova closed this task as Resolved.Sep 22 2017, 7:03 PM
Etonkovidova reopened this task as Open.Sep 23 2017, 12:34 AM

Uh oh. What's up?

@Mooeypoo re-opened - the issue is still present in FF 55.

Change 380654 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/core@master] RCFilters: Also set toplinks-collapsed class if no cookie

https://gerrit.wikimedia.org/r/380654

@Mooeypoo re-opened - the issue is still present in FF 55.

@Etonkovidova and I debugged this over hangouts and it turns out that the PHP code interpreted missing cookies differently than the JS code. My patch fixes this.

Change 380654 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Also set toplinks-collapsed class if no cookie

https://gerrit.wikimedia.org/r/380654

Re-checked in betalabs - FF and Chrome (and the case with cookies cleared) - the community links behave as expected: they do not un-collapsed during RC page load.

T176687: [minor] Legend expands and collapses when the page loads on RC page and Watchlist is about the same issue with the Legend.

QA Recommendation: Resolve

jmatazzoni closed this task as Resolved.Sep 26 2017, 4:10 PM