Page MenuHomePhabricator

Document difference between spec.yaml and spec.template.yaml
Closed, InvalidPublic

Description

The in-repo guide refers to spec.template.yaml, but only spec.yaml has the geoline service.

Event Timeline

Pnorman created this task.Sep 21 2017, 6:45 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 21 2017, 6:45 PM
Pnorman reopened this task as Open.Sep 21 2017, 7:42 PM
Pnorman added a subscriber: Bnhassin.

@Bnhassin this task isn't related to the one you marked it as a duplicate of, so I've reopened it.

I think both of these are from the service template. CC @services group.

mobrovac added a subscriber: mobrovac.

Correct. spec.template.yaml is a spec template that should be used to create the actual spec.yaml for your service.

debt triaged this task as Normal priority.Sep 22 2017, 1:40 PM
debt added a project: Discovery.

So we should keep the spec.yaml and remove the spec.template.yaml? The latter appears to contain nothing relevant to kartotherian.

So we should keep the spec.yaml and remove the spec.template.yaml? The latter appears to contain nothing relevant to kartotherian.

Correct.

Pnorman moved this task from In progress to Backlog on the Maps-Sprint board.
Mholloway moved this task from Backlog to To-do on the Maps-Sprint board.Jul 3 2018, 4:55 PM
mobrovac closed this task as Invalid.Jul 4 2018, 6:28 AM

There is no difference between the two - as the names suggest spec.template.yaml is a template for spec.yaml. Sometimes it's that simple :)