Page MenuHomePhabricator

Advanced search looks all bunched into right hand column on enwikipedia
Closed, ResolvedPublic

Description

For https://en.wikipedia.org/w/index.php?search=foofdafdas&title=Special:Search&profile=advanced the namespace selector is all weirdly bunched on the right hand side.

This seems to be caused by the margin: -1px, 0, 0; rule added in https://gerrit.wikimedia.org/r/#/c/376660 (052abe72). Perhaps it was meant to be margin: -1px, 0, 0, 0; instead?

Event Timeline

Bawolff created this task.Sep 22 2017, 4:38 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 22 2017, 4:38 PM

Screenshot might help? I don't see anything strange, after testing in: wide window, narrow window, monobook, in both Firefox55 and Chromium61.

@Bawolff Also, this screenshot below would be the UI with setting margin: 0 as before the mentioned change (so without negative 1px top margin):

It was only meant to visually connect things, that belong together.

(affects Vector too, not a MonoBook issue only)

Not reproducible for me yet, similar to @Quiddity. Neither in Firefox, nor Chrome, not in Vector, nor in Monobook.

From conversation with @Legoktm, it's now reproducible:

legoktm> Volker_E: I have zoom set to 120%. Resetting it to 100% makes the layout look normal. In Chromium zoom levels 100%-125% look fine though

Change 379841 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/core@master] Fix unintended margin when zoom level is above 100%

https://gerrit.wikimedia.org/r/379841

Volker_E triaged this task as Medium priority.Sep 22 2017, 8:41 PM

Change 379841 merged by jenkins-bot:
[mediawiki/core@master] SpecialSearch: Fix unintended margin when zoom level is above 100%

https://gerrit.wikimedia.org/r/379841

Change 379903 had a related patch set uploaded (by Legoktm; owner: VolkerE):
[mediawiki/core@REL1_30] SpecialSearch: Fix unintended margin when zoom level is above 100%

https://gerrit.wikimedia.org/r/379903

Change 379903 merged by jenkins-bot:
[mediawiki/core@REL1_30] SpecialSearch: Fix unintended margin when zoom level is above 100%

https://gerrit.wikimedia.org/r/379903

Izno added a subscriber: Izno.Oct 5 2019, 8:21 PM

This looks to have been resolved @Legoktm @Volker_E ?

Volker_E closed this task as Resolved.Oct 25 2019, 2:50 PM
Volker_E removed a project: Patch-For-Review.