Page MenuHomePhabricator

Contribution page: 'Hide probably good edits' displays entries that do not get ORES highlighted
Closed, ResolvedPublic

Description

  1. In betalabs set 'Prediction treshold' to 'May have problems...' and enable 'Highlight likely problem edits with colors and an "r" for "needs review".
  2. Go to Contribution page. Select a user that made some damaging edits - you may find such a user on RC page with Damaging filters and user filters.
  3. The Contribution page will display the results for that user marked with highlight and r.
  4. Check 'Hide probably good edits' - there will be still some edits not highlighted.

It seems that non-highlighted entries are all SD page edits.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 25 2017, 8:20 PM
Etonkovidova updated the task description. (Show Details)Sep 25 2017, 8:21 PM

@Etonkovidova will check how ORES interacts with Flow.

It seems that Flow type entires do not get ORES scores.

@deployment-db04[enwiki]> select count(*) from ores_classification where oresc_rev in (select rc_this_oldid from recentchanges where rc_type=142);
+----------+
| count(*) |
+----------+
|        0 |
+----------+
1 row in set (0.01 sec)

However, the issue is still valid - 'Hide probably good edits' should hide not-ORES-scored Flow entries.

However, the issue is still valid - 'Hide probably good edits' should hide not-ORES-scored Flow entries.

In my opinion, it should not hide Flow entries.

Since ORES doesn't have a prediction on Flow entries (T177245: Implement "orientation" for Flow's Structured Discussion revisions), I don't think any ORES filters should hide Flow rows.

For example, in this case, the user is intending to skip pages that probably don't need review. ORES is unable to make that prediction for Flow, so they shouldn't be skipped.

Etonkovidova added a comment.EditedOct 2 2017, 6:57 PM

There is a certain logic in not hiding non-ORES scored entries, yes. However, users are unaware of the fact that certain types of edits cannot be ORES-scored.
From the user point of view, the filter 'Hide probably good edits' fetches only damaging edits. Seeing entires that are not highlighted by ORES is confusing - a user may ask: the filter 'Hide probably good edits' does not work? Is there is another scoring system in place (non-ORES) that makes those edits to be marked as damaging?

Maybe we could have another highlighting color (or even a letter) to indicate unknown ORES status. We could also use this on the few normal revisions it fails to score.

@Etonkovidova Triage notes says that you are going to figure out what to do with this. have you?

The option 'Hide probably good edits' should display only edits marked by ORES as damaging - no un-scored entries should be displayed.

Harej added a subscriber: Harej.Apr 3 2019, 1:21 AM

Please confirm whether this task requires work from the Scoring Platform Team.

Harej removed a subscriber: Harej.Jul 4 2019, 9:26 AM
JTannerWMF added a subscriber: JTannerWMF.

@Etonkovidova will take a look at this

@Harej - no work is required from the Scoring Platform Team at this point.

Checked in betalabs and in production - Special:Contributions do not get any highlighting at all. The issue reported in this task cannot be actually confirmed or dismissed as non-existing.

Special:Preferences page indicates that highlighting should be displayed on Contributions page, but non-highlighting could be a change in functionality. @Catrope - can you confirm that?


Yeah it looks like the highlighting on Special:Contributions went away completely, and I'm not aware of that being deliberate. I'll investigate.

Yeah it looks like the highlighting on Special:Contributions went away completely, and I'm not aware of that being deliberate. I'll investigate.

Highlighting on Special:Contributions is still there. It is controlled by oresHighlight, which can be set in Preferences -> Watchlist -> Highlight likely problem edits with colors and an "r" for "needs review" I don't remember why it ended up under Watchlist.

Change 525135 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/extensions/Flow@master] ORES hidenondamaging filters out Flow entries from Special:Contributions

https://gerrit.wikimedia.org/r/525135

Change 525135 merged by jenkins-bot:
[mediawiki/extensions/Flow@master] ORES hidenondamaging filters out Flow entries from Special:Contributions

https://gerrit.wikimedia.org/r/525135

Etonkovidova closed this task as Resolved.Jul 25 2019, 12:31 AM

Checked the fix in betalabs - works as expected.

Note: Regarding the following - yes, the setting in Watchlist for highlight in Contributions works which does not make much sense.

Yeah it looks like the highlighting on Special:Contributions went away completely, and I'm not aware of that being deliberate. I'll investigate.

Highlighting on Special:Contributions is still there. It is controlled by oresHighlight, which can be set in Preferences -> Watchlist -> Highlight likely problem edits with colors and an "r" for "needs review" I don't remember why it ended up under Watchlist.

Special:Preferences - Recent changes specifically refers to Contributions page in its setting for highlighting :

Special:Preferences - Watchlist doesn't mention Contributions:

Filed as T228951.