Page MenuHomePhabricator

Re-enable monuments_without_id reports
Closed, ResolvedPublic

Description

The images_of_monuments_without_id script is not being run as part of the update_monuments bash script or any other script in cron.

This task aims to investigate why and implement the necessary fixes to make at least the imagesWithoutId reports work again.

Related Objects

Event Timeline

Lokal_Profil added subscribers: Multichill, JeanFred.

@JeanFred @Multichill: Have you got any memories of why this was deactivated or when?

Dunno, what happens if you do a manual run? Does everything explode?

I stated a run with the pywikibot -simulate flag on toolforge (job name NoIdTest). Next step is probably to do a run with the addCommonsTemplate() function deactivated before trying it for a particular country.

So taking a quick look at the log it seems as though the bot tries to add the template even if it is already there. (at least for Switzerland)

First step would be to add a flag to disable/enable adding the templates. That way we can at least get galleries up and running.

For T203338 it would not be bad to add a flag which only looks in the base category since for categorisation these are the important ones to fix.

Lokal_Profil renamed this task from Investigate why monuments_without_id is not run to Re-enable monuments_without_id reports.Sep 14 2018, 2:01 PM
Lokal_Profil updated the task description. (Show Details)

Change 463850 had a related patch set uploaded (by Lokal Profil; owner: Lokal Profil):
[labs/tools/heritage@master] Re-enable Images without id reports

https://gerrit.wikimedia.org/r/463850

Change 463850 merged by jenkins-bot:
[labs/tools/heritage@master] Re-enable Images without id reports

https://gerrit.wikimedia.org/r/463850