Page MenuHomePhabricator

CX2: Restore the saved translation
Closed, ResolvedPublic

Description

The translation of sections edited by VE are saved. They need to be restored against its source sections when translation is resumed.

  • The basic algorithm is to match against the section identifiers.
  • If source article changed heavily, we need to use a better algorithm to identify source sections even if it changed. T204308: Use content matching of source sections for improving the translation restore (Showing a warning to the user is part of a separate ticket, T168287: CX2: Warning about article having changed too much)
    • Support CX1 translations by relying on parsoid generated ids
    • Restoring translations against source sections even if those sections moved around.
  • And fallback to original source revision if source article changed beyond restoring a saved translation.
  • Status message about fetching the saved translation should be shown to translator
  • Status message about restoring the fetched translation should be shown to translator
  • Restore the modified translation title if any

With the recent regressions (T187683), this ticket requires to re-evaluate the checked boxes above, and completing the remaining ones.

Details

Related Gerrit Patches:
mediawiki/extensions/ContentTranslation : masterCX2: Mark the restored sections and log if anything not restored
mediawiki/extensions/ContentTranslation : masterRestore translations - enhancements
mediawiki/extensions/ContentTranslation : masterCX2: Refactoring for translation restore when source article changed
mediawiki/extensions/ContentTranslation : masterCX2: Restore the saved translation

Event Timeline

santhosh created this task.Sep 27 2017, 9:07 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 27 2017, 9:07 AM

Change 380935 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@master] CX2: Restore the saved translation

https://gerrit.wikimedia.org/r/380935

santhosh triaged this task as Medium priority.Sep 27 2017, 9:14 AM
santhosh updated the task description. (Show Details)
santhosh moved this task from Backlog to In Progress on the Language-2017-July-Sept board.

Change 380935 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] CX2: Restore the saved translation

https://gerrit.wikimedia.org/r/380935

santhosh updated the task description. (Show Details)Oct 17 2017, 11:44 AM

Change 384934 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@master] CX2: Refactoring for translation restore when source article changed

https://gerrit.wikimedia.org/r/384934

Change 384934 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] CX2: Refactoring for translation restore when source article changed

https://gerrit.wikimedia.org/r/384934

Change 388429 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@master] Restore translations - enhancements

https://gerrit.wikimedia.org/r/388429

Change 388429 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Restore translations - enhancements

https://gerrit.wikimedia.org/r/388429

santhosh updated the task description. (Show Details)Nov 8 2017, 9:21 AM
Pginer-WMF raised the priority of this task from Medium to High.Feb 16 2018, 9:40 AM
Pginer-WMF updated the task description. (Show Details)Feb 19 2018, 9:22 AM

Change 421473 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@master] CX2: Mark the restored sections and log if anything not restored

https://gerrit.wikimedia.org/r/421473

Change 421473 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] CX2: Mark the restored sections and log if anything not restored

https://gerrit.wikimedia.org/r/421473

Details about the warning when the article changed too much are available in T168287: CX2: Warning about article having changed too much

santhosh removed santhosh as the assignee of this task.Apr 9 2018, 7:18 AM
santhosh updated the task description. (Show Details)Sep 26 2018, 10:01 AM
  • And fallback to original source revision if source article changed beyond restoring a saved translation.

Since T168287: CX2: Warning about article having changed too much was completed, I think we can check the remaining item, and close this ticket. @santhosh, can you confirm, or indicate if anything else is still missing in this area?

Pginer-WMF closed this task as Resolved.Jul 1 2019, 12:39 PM
Pginer-WMF claimed this task.
Pginer-WMF updated the task description. (Show Details)

Basic support is in place now. Further improvements such as T220790: Restore using updated content only when no user data is lost, using the original version as a fallback captured in separate tickets.