Page MenuHomePhabricator

Icons missing throughout UI on Edge, IE 11
Closed, ResolvedPublic

Description

On test URL https://test.wikipedia.org/wiki/File:Programmatically_created_crystal.stl the icons for the view and download buttons on a 3d object view don't show in Edge and IE 11 (Windows 10 Creators Update). Everything works once viewer is loaded, but the icons are missing before you get there.

Details:
Browser: Microsoft Edge
Computer Version: Windows 10 Version 1703 (OS Build 15063.608)
MediaWiki Version: 1.31.0-wmf.1 (963972f)

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
Restricted Application added a project: Multimedia. · View Herald TranscriptSep 27 2017, 4:13 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
brion added a comment.Sep 27 2017, 4:15 PM

Looking further I see missing icons all throughout the media viewer interface. Something underlying?

gh87 added a subscriber: gh87.Sep 27 2017, 9:21 PM

Not just Test Wikipedia. Meta-wiki has experienced the same issue. The alerts (bell), notices (box), watchlist button (star), and external link (arrow) icons are invisible. Other projects, like Wikimedia Commons and Wiktionary, experience the similar issues. Icons still appear on Wikipedia; I believe that non-Wikipedia projects have the icon visibility issue.


The above images are captured from Meta-wiki. I just modified the images, one to enhance awareness, other to black out the list of alerts.

The title should be changed to "Icons invisible on non-Wikipedia projects in IE11", shouldn't it? Or that would be a separate task.

Liuxinyu970226 added a subscriber: Liuxinyu970226.

I don't think this problem affects the whole MediaWiki sites of the world, at least it works for me on MW.org and Wikidata

I didn't know about the "Browser" tags. On IE11, Wikidata and MW.org still have invisible icons.

Liuxinyu970226 added a comment.EditedSep 27 2017, 10:52 PM

I didn't know about the "Browser" tags. On IE11, Wikidata and MW.org still have invisible icons.

By geographical, where are you living? Mainland China? Russia? Iran?...

Your problem reads rather territorial than commonly

gh87 added a comment.EditedSep 28 2017, 1:11 AM

@Liuxinyu970226 Is the question rhetorical? If not, would you please eliminate the question (or delete T176884#3641425). I'd rather not answer what you ask me. Thanks. BTW, may we continue discussing you and me at Meta-wiki or somewhere else please? You and I need a talk.

Liuxinyu970226 added a comment.EditedSep 28 2017, 1:15 AM

@Liuxinyu970226 Is the question rhetorical? If not, would you please eliminate the question (or delete T176884#3641425). I'd rather not answer what you ask me. Thanks. BTW, may we continue discussing you and me at Meta-wiki or somewhere else please? You and I need a talk.

I'm not asking rhetorical, I just want to know if this issue is reproducible by all users or not, as I don't believe that all Windows 10 users can face-to-face this task by just using IE11/Edge. (Please, believe me, there should have more conditions in order to always reproduce it, with just Windows 10 and using IE can give some users works-for-me interfaces.)

Anyway, as per @gh87

The alerts (bell), notices (box), watchlist button (star), and external link (arrow) icons are invisible.

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptSep 28 2017, 1:18 AM
gh87 added a comment.EditedSep 28 2017, 1:23 AM

My apologies, @Liuxinyu970226. I struck out my previous comment as misunderstanding one of your posts. I just... I should have asked for clarity earlier. I just got frustrated. That's all.

EDIT: Still, asking me about my location... that's when I got frustrated

gh87 added a comment.Sep 29 2017, 12:43 AM

Now the bug has extended to Wikipedia, i.e. Wikipedia is having similar IE/Edge issues lately.

Mattflaschen-WMF renamed this task from View and download icons for 3d object don't show on Edge, IE 11 to Icons missing throughout UI on Edge, IE 11.Sep 29 2017, 2:15 AM
Mattflaschen-WMF triaged this task as Unbreak Now! priority.Sep 29 2017, 2:18 AM

Confirmed in Edge 15 on Windows 10:

Restricted Application added subscribers: Jay8g, TerraCodes. · View Herald TranscriptSep 29 2017, 2:18 AM

Facing the same problem as described in the above screenshot.Microsoft Edge/Win 10 (Dev build-Fast ring).

Volker_E added a comment.EditedSep 29 2017, 10:49 AM

That's highly probable caused by the inline SVG optimizations (T175318) around https://gerrit.wikimedia.org/r/#/c/377820/

Code seemingly must have changed for failure in the course of the patches as the original test works in Edge and IE11 (logo on the right is the optimized one):
https://codepen.io/Volker_E/full/BwyQwo/ – updating test case with broken SVG…

Volker_E added subscribers: Krinkle, matmarex.

Change 381430 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/core@master] Revert "CSSMin: Improve encoding of quotes in embedded SVGs"

https://gerrit.wikimedia.org/r/381430

Change 381443 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/core@master] Revert "CSSMin: Mangle whitespace in embedded SVGs"

https://gerrit.wikimedia.org/r/381443

Change 381443 merged by jenkins-bot:
[mediawiki/core@master] Revert "CSSMin: Mangle whitespace in embedded SVGs"

https://gerrit.wikimedia.org/r/381443

Change 381430 merged by jenkins-bot:
[mediawiki/core@master] Revert "CSSMin: Improve encoding of quotes in embedded SVGs"

https://gerrit.wikimedia.org/r/381430

Change 381485 had a related patch set uploaded (by Catrope; owner: Esanders):
[mediawiki/core@wmf/1.31.0-wmf.1] Revert "CSSMin: Mangle whitespace in embedded SVGs"

https://gerrit.wikimedia.org/r/381485

Change 381486 had a related patch set uploaded (by Catrope; owner: VolkerE):
[mediawiki/core@wmf/1.31.0-wmf.1] Revert "CSSMin: Improve encoding of quotes in embedded SVGs"

https://gerrit.wikimedia.org/r/381486

Change 381485 merged by Catrope:
[mediawiki/core@wmf/1.31.0-wmf.1] Revert "CSSMin: Mangle whitespace in embedded SVGs"

https://gerrit.wikimedia.org/r/381485

Change 381486 merged by Catrope:
[mediawiki/core@wmf/1.31.0-wmf.1] Revert "CSSMin: Improve encoding of quotes in embedded SVGs"

https://gerrit.wikimedia.org/r/381486

Mentioned in SAL (#wikimedia-operations) [2017-09-29T18:19:55Z] <catrope@tin> Synchronized php-1.31.0-wmf.1/includes/libs/CSSMin.php: T176884 (duration: 00m 47s)

Catrope closed this task as Resolved.Sep 29 2017, 6:22 PM
Catrope claimed this task.

I tested before and after the deployment using IE 11 on SauceLabs, and the icons appear for me now. It's possible that there might be caching issues with the old icons; if you still don't see the icons, try hard-refreshing (Ctrl+F5), and if that doesn't help, complain on this task :)

I tested before and after the deployment using IE 11 on SauceLabs, and the icons appear for me now. It's possible that there might be caching issues with the old icons; if you still don't see the icons, try hard-refreshing (Ctrl+F5), and if that doesn't help, complain on this task :)

In Microsoft Edge the icons for notification, messages and watchlist are still missing:


I tried CTRL+F5, that didn't help.

In Microsoft Edge the icons for notification, messages and watchlist are still missing:

Thanks for reporting that. I'm looking into ways to bust the cache for these icons, but it's not easy. I've asked @Krinkle for help on IRC.

Catrope reopened this task as Open.Sep 29 2017, 8:04 PM

Change 381503 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/core@master] ResourceLoaderModule: Add cache version to definition summary

https://gerrit.wikimedia.org/r/381503

UpsandDowns1234 closed this task as Resolved.Sep 30 2017, 1:02 AM

Closing, this issues appears to be fixed.

UpsandDowns1234 reopened this task as Open.Sep 30 2017, 1:02 AM

or not

Not for everyone, no, it seems some people are still getting cached CSS from before the bug was fixed (this could be a geographical difference, with people in Europe still seeing the bug but people on other continents not seeing it) . We don't have a good way to invalidate the cache when something like this happens. My patch (linked by gerritbot above) implements one, but it needs to be reviewed by someone familiar with ResourceLoader and its caching, and the main candidate for that lives in the Europe where it's the middle of the night (very early Saturday morning) right now :/

I notice that the problem is with some sites (like Wikipedia) but not others.

I notice that the problem is with some sites (like Wikipedia) but not others.

Please be specific. "some sites [...] but not others" is too vague. Thanks.

Change 381581 had a related patch set uploaded (by Catrope; owner: Catrope):
[operations/mediawiki-config@master] Bump $wgResourceLoaderStorageVersion

https://gerrit.wikimedia.org/r/381581

Change 381581 merged by jenkins-bot:
[operations/mediawiki-config@master] Bump $wgResourceLoaderStorageVersion

https://gerrit.wikimedia.org/r/381581

Mentioned in SAL (#wikimedia-operations) [2017-09-30T20:54:51Z] <catrope@tin> Synchronized wmf-config/CommonSettings.php: Bump $wgResourceLoaderStorageVersion (T176884) (duration: 00m 47s)

greg added a subscriber: greg.Oct 2 2017, 9:11 PM

Status?

gh87 added a comment.EditedOct 3 2017, 5:39 AM

@greg The icons now appear on all projects except Wikipedia, and I'm using IE11.

EDIT: Now the icons appear also on Wikipedia.

RE-EDIT: Never mind. The icons now appear only on non-Wikipedia projects. Somehow, Wikipedia is again affected.

@gh87

RE-EDIT: Never mind. The icons now appear only on non-Wikipedia projects. Somehow, Wikipedia is again affected.

I'm sorry but which icon? Of external links (i.e. External.svg)?

gh87 added a comment.Oct 5 2017, 5:45 AM

@Liuxinyu970226 All icons, including the external links arrow, are working on non-Wikipedia projects. I tried Wikipedia again; icons come and go. However, I see them in my watchlist and most other non-article pages, but I don't see them in articles.

Liuxinyu970226 added a comment.EditedOct 5 2017, 7:18 AM

@gh87 All icons? no exception? (Includes the "In other languages '''gear'''"? Includes icons on the actual browser? Includes "大/A" of Contenttranslation?) And still, as per @Catrope above, this really really and really is somewhat geographical (at least, I don't believe that this is still happened in China (I'm altering hosts file to visit...)), so if you still aganist providing the necessary geo informations we can't process solving

Liuxinyu970226 added a comment.EditedOct 5 2017, 7:27 AM

@Mattflaschen-WMF Since this is just affecting some countries (not all), would downgrading priority to "High" be sense?

Can this task be closed as "resolved" now? The icons reappear on Wikipedia.

gh87 added a comment.Oct 6 2017, 2:22 AM
This comment was removed by gh87.
gh87 added a comment.Oct 6 2017, 2:35 AM

@Liuxinyu970226 In zh.WP, the icons also reappear. So do it.WP, fr.WP, etc.

Liuxinyu970226 closed this task as Resolved.Oct 6 2017, 3:53 AM

Can this task be closed as "resolved" now? The icons reappear on Wikipedia.

+1

Liuxinyu970226 lowered the priority of this task from Unbreak Now! to High.EditedOct 12 2017, 4:47 AM

Not all countries, so downgrade to High (feel free to re-upgrade if you believe that this has error on database level)

Change 381503 merged by jenkins-bot:
[mediawiki/core@master] resourceloader: Add filter cache version to module version hash

https://gerrit.wikimedia.org/r/381503

Restricted Application added a project: Performance-Team. · View Herald TranscriptSep 24 2018, 5:38 PM
gh87 removed a subscriber: gh87.Sep 28 2018, 3:50 PM