Page MenuHomePhabricator

StructuredDiscussions: Spam Blacklist eats text
Closed, ResolvedPublic

Description

When submitting a comment that contains a blacklisted link, Flow appears to eat the comment. This is especially unfortunate given that the URL shortening service used by Wikimedia's own query service is on the spam blacklist, as demonstrated below (animated GIF, click to play):

Unfortunately, the "back" button doesn't work in this case either given that we're not on a new page, which may add to the frustration/confusion.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Eloquence updated the task description. (Show Details)Sep 28 2017, 12:28 AM
Eloquence updated the task description. (Show Details)

Checked the behavior of AbuseFilter (#461) in betalabs - the warning is displayed and the content is not posted, but the text is not removed form the editing area. So, it might be the specific behavior for that spam filter or type of filters - need more investigtion.

Checked the behavior of AbuseFilter (#461) in betalabs - the warning is displayed and the content is not posted, but the text is not removed form the editing area. So, it might be the specific behavior for that spam filter or type of filters - need more investigtion.

It's not AbuseFilter, it's SpamBlacklist. This was on mediawiki.org though, so you should be able to test this at https://www.mediawiki.org/wiki/Talk:Sandbox

Thanks, @Catrope!

The issue is reproducible (https://www.mediawiki.org/wiki/Talk:Sandbox):

  • start a new topic - this is the only case when the issue is reproducible
  • follow the gif in the issue: type the topic title, type the first line, paste the link (that blocked by SpamBlacklist), click to save. The comment will be deleted, the warning will be displayed. Undo or Back does not work.

Listed below are the cases when the issue is not present:

  • If the link is in the bulk of pasted text, the link is not rendered as a link (<nowiki>) is added. The text can be saved.
  • If the link is added as a comment to already existing topic. The warning will appear and the text won't be saved, but the comment won't disappear.
  • If the link is added as a part of editing existing text. The warning will appear and the text won't be saved, but the comment won't disappear.
Restricted Application added a project: Growth-Team. · View Herald TranscriptJul 31 2018, 5:05 PM
JTannerWMF moved this task from Inbox to To Triage on the Growth-Team board.Aug 9 2018, 6:25 PM
JTannerWMF added a subscriber: JTannerWMF.

Team will research next steps to determine how to proceed.

@Etonkovidova I can't reproduce this anymore. I'm thinking it was probably fixed when the Flow editor was re-implemented to include the new wikitext editor.

Could you check it and close if appropriate? thanks

Etonkovidova closed this task as Resolved.Sep 25 2018, 7:34 PM

Checked in betalabs - the comment which triggers MediaWiki:Spam-blacklist message will not disappear - users will have a chance to correct their text to remove text that triggered the message: