Page MenuHomePhabricator

Run fundraising test via announcment cards in France
Closed, ResolvedPublic

Description

We would like to test in app fundraising as part of the French annual fundraiser. There will be a second banner later in October, but given that I totally fucked up following up on this, I just wanted to get the first one filed. Note that the start date is Oct 3rd, so let me know whats realistic given the late date of filing.

Main text

Le moment est venu de faire appel à vous.

Chers lecteurs en France, nous irons droit au but : aujourd’hui, nous vous demandons d’aider Wikipédia. Afin de protéger notre indépendance, nous ne diffuserons jamais de publicité. Nous sommes soutenus par des dons d’environ 10 € en moyenne. Nos lecteurs sont très peu nombreux à faire des dons. Si chaque personne qui lit ce message donnait 2 €, cela permettrait à Wikipédia de continuer à prospérer de nombreuses années. Le prix d’un café, c’est tout ce dont nous avons besoin. Si Wikipédia vous est utile, prenez une minute afin de maintenir cette plate-forme en ligne et lui permettre de continuer de croître. Merci.

Legal footer

Un problème pour faire un don ? | Autres façons de donner | Questions fréquentes | En faisant ce don, vous acceptez notre politique de confidentialité en matière de donation ainsi que de partager vos données personnelles avec la Wikimedia Foundation et ses prestataires de services situés aux États-Unis et ailleurs. Si vous faites un versement périodique, vous serez débité à chaque échéance par la Wikimedia Foundation jusqu’à ce que vous nous indiquiez d’arrêter. Nous vous enverrons une confirmation par courriel pour chaque paiement, qui inclura un lien vers des instructions faciles d’annulation.

Image

No image in v1

Button text

Continue/OK button : Continuer
Close/Cancel : Fermer

Target URLs

Android: https://donate.wikimedia.org/?uselang=fr&utm_medium=WikipediaAppFeed&utm_campaign=Android&utm_source=app_201710_FR_control

iOS: https://donate.wikimedia.org/?uselang=fr&utm_medium=WikipediaAppFeed&utm_campaign=iOS&utm_source=app_201710_FR_control

Dates to display

3 - 17 October

Countries

This should only be shown to users in France.

Event Timeline

JMinor created this task.Sep 28 2017, 6:27 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 28 2017, 6:27 PM

@JMinor to add the button text shortly

@JMinor @Dbrant @JoeWalsh

Can you handle this long of a legal footer in the announcement card?

Note: the legal footer is the caption HTML property

JMinor updated the task description. (Show Details)Sep 29 2017, 6:18 PM

Yeah, goood question on the footer. Its is very long. I will look back at if there was a limit, design wise. I think it just makes the card really long, but will verify before we push.

Added the button text. Not sure if we need cancel as well, so included both OK and cancel strings.

@JMinor on the footer… previously the idea was just to have this field as a small blurb with a link to the longer prose about legalities.

If we kept the same concept here, I would probably recommend moving this text to a page (on mediawiki?) and then we link to it from the footer.

But we can also just see how this looks in the apps, but I am guessing that this will be a very long card

Yeah, no technical issues with the amount of text, but that is an awfully long footer. Here's how it looks on my (generously-sized) device:


Ideally it shouldn't really be longer than two lines, with a link to a wiki page that contains additional content.

Yeah, I can ask advancement if the full text needs to be visible in line.
Some of this is regulatory stuff we can't control :(

@JoeWalsh can you verify that iOS can handle this as well?

Or @Mhurd can you look if Joe is out?

Since the card is just linking to https://donate.wikimedia.org where we also have all those links and legal blurb, I don't think we need it in the card itself. @jrobell can you confirm?

Change 381507 had a related patch set uploaded (by BearND; owner: BearND):
[mediawiki/services/mobileapps@master] Add fundraising test via announcement cards in France

https://gerrit.wikimedia.org/r/381507

I've started a patch ^ but blocked it until:

  1. we get a final decision on the caption_HTML and
  2. confirmation from an iOS dev to verify that it works for that, too.

For the app devs, I left also some QA notes in the commit message of the patch.

The timeline is tight. But if I get this deployed by the end of the services deployment window on Monday and considering a cache duration of 2 hours the change should be live before midnight UTC on Tuesday.

I commented and moved out the image_url for iOS and image for Android. I hope that works for iOS. I've tested this on Android only. We need someone to test this patch for iOS.

I made up some announcement ids: FR1017FRIOS and FR1017FRANDROID. Ping me if you want that changed.

bearND claimed this task.Sep 29 2017, 10:54 PM
bearND triaged this task as High priority.

Here is the Android version again, this time on a smaller device (Nexus 5):

And after scrolling down to the end and changing device language to French:

One more thing I noticed is that the links in the caption_HTML have a utm_source parameter with a date of mid September.
caption_HTML: utm_source=frFR_dsk_p1_lg_control_17_09_14
But action has something about October: utm_source=app_201710_FR_control

Thank you everyone for your work getting this ready.

I think it will be fine to leave out the legal text from the actual banner, as we have it on donatewiki as @Pcoombe mentioned. I need to confirm this with legal though and have a call with them Monday morning PST. As soon as I have thumbs up from legal, I'll confirm.

Thanks!

@Mhurd to verify client support in iOS today.

bearND added a comment.Oct 2 2017, 6:55 PM

@jrobell, @Pcoombe, @JMinor any updates to the legal footer text (aka caption_HTML)? Should it just be an empty string or even undefined? Or is there a short text we should put in?

Mhurd added a comment.Oct 2 2017, 9:29 PM

@JMinor @bearND @JoeWalsh :

The announcement text is so big it's super explodey on iOS:

There's an issue with overlapping with card beneath as well:

JMinor added a comment.Oct 2 2017, 9:32 PM

Ok. I think we'll end up with much less text, but I need @jrobell to confirm that compliant with legal/advancement policy.

Just a heads up that this will need to start on the 4th at the earliest.

@Mhurd that card it bleeds into has special handling (its only shown on first use, whereas the announcement is supposed to NEVER shown on first use.) Can you dismiss that card and see if it bleeds into more standard content cards?

bearND added a comment.Oct 2 2017, 9:40 PM

@Mhurd would you also check how often the iOS app checks for announcement updates? If this is done only once per day then I think it would be better to make the start date even later (> 24h before midnight UTC), which basically means: if I deploy on Tuesday the start day should be Thursday midnight UTC at the earliest.

Mhurd added a comment.Oct 2 2017, 9:46 PM

@Mhurd that card it bleeds into has special handling (its only shown on first use, whereas the announcement is supposed to NEVER shown on first use.) Can you dismiss that card and see if it bleeds into more standard content cards?

@JMinor it looks like they can both show if the user hasn't dismissed the other card...

Mhurd added a comment.Oct 2 2017, 9:52 PM

Here it is on iPhone 6 (note that we support much smaller devices - ie iPhone 4s etc)

Here it is with the "caption_HTML" footer shortened to just the first 3 links:

Thank you all for your work on this. The legal team confirmed that we only need the legal footer when we're processing info directly in a banner or send someone off to a 3rd party site without showing them the privacy policy link at some point. Hence, we do not need to show the disclaimer in the in-article banner if readers are sent to [[ URL | donatewiki ]] to finalize the donation.

The shorter version with just 3 links looks good to me.

Let us know if you need anything else in order to deploy.

Thanks!

bearND added a comment.Oct 3 2017, 5:53 PM

@JMinor Does the main text stay the same? Looks like we only need the first three links in the disclaimer. I will update the patch accordingly (Thank you, @jrobell!). I'm going to add 2 extra days to the start and end dates to account for the delay. Sound good?

The main text does stays the same. Thank you @bearND ! As discussed with @JMinor, we'd like to run a simple A/B test though, testing some different copy, Can we let this version run two weeks and swap it with a slightly different variations for the last 2 weeks of the campaign?

JMinor added a comment.Oct 3 2017, 7:50 PM

@bearND confirmed. Please use the main text as is, and only the links for the disclaimer (the result should look like mhurd screenshot). Starting 2 days delayed is fine.

bearND added a comment.Oct 3 2017, 7:53 PM

@JMinor Yes, the patch is updated accordingly. I just need someone to +2 it (pinged a couple of devs on wikimedia-mobile channel). Then I'll deploy it.

@jrobell Sure, we can change it with a different variation after a certain time. We'd probably want to use different ids for that, to ensure a clean cut-off if that is important. The donation urls can stay the same or be different. That's up to you. It would be great to finalize what the new values should be ahead of time so we can deploy it early enough.

Change 381507 merged by jenkins-bot:
[mediawiki/services/mobileapps@master] Add fundraising test via announcement cards in France

https://gerrit.wikimedia.org/r/381507

Stashbot added a subscriber: Stashbot.

Mentioned in SAL (#wikimedia-operations) [2017-10-03T22:20:38Z] <bsitzmann@tin> Started deploy [mobileapps/deploy@82aa7d6]: Update mobileapps to 5dc0c02 (T175762 T177001 T176525 T176517 T176519)

Mentioned in SAL (#wikimedia-operations) [2017-10-03T22:26:53Z] <bsitzmann@tin> Finished deploy [mobileapps/deploy@82aa7d6]: Update mobileapps to 5dc0c02 (T175762 T177001 T176525 T176517 T176519) (duration: 06m 14s)

The patch is deployed. It can take up to 4 hours for the update to become visible at https://fr.wikipedia.org/api/rest_v1/feed/announcements.

@bearND the fundraiser is complete and this can be removed from the MCS whenever you like.

Change 386268 had a related patch set uploaded (by BearND; owner: BearND):
[mediawiki/services/mobileapps@master] Revert "Add fundraising test via announcement cards in France"

https://gerrit.wikimedia.org/r/386268

Change 386268 merged by jenkins-bot:
[mediawiki/services/mobileapps@master] Revert "Add fundraising test via announcement cards in France"

https://gerrit.wikimedia.org/r/386268

Mholloway closed this task as Resolved.Nov 6 2017, 10:27 PM
bearND reopened this task as Open.Nov 8 2017, 3:13 AM

The revert hasn't been deployed yet but will be soon. Hopefully tomorrow.

Mholloway closed this task as Resolved.Jan 10 2018, 3:54 PM