Page MenuHomePhabricator

Composer failed in Selenium job but job didn't stop
Closed, ResolvedPublic

Description

https://integration.wikimedia.org/ci/job/mwext-mw-selenium-composer-jessie/6334/console

composer update has failed but the script continued to execute.
I guess it is not very big deal but makes log reading a bit harder.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 29 2017, 9:13 AM
Legoktm triaged this task as Low priority.Oct 5 2017, 6:33 AM

The shell snippet being run is:

set -u
cd "src"
[[ -f "composer.json" ]] || exit 0
composer update --ansi --no-progress --prefer-dist --profile -v

Jenkins save it in a temporary file then run it via bash -xe the output is:

00:01:38.089 [376.2MB/43.79s] Dependency resolution completed in 2.335 seconds
00:01:38.099 [376.3MB/43.80s] Your requirements could not be resolved to an installable set of packages.
00:01:38.101 [376.3MB/43.80s] 
00:01:38.101   Problem 1
00:01:38.101     - The requested package data-values/data-types ^1.0.0 exists as data-values/data-types[dev-REL1_30, dev-master] but these are rejected by your constraint.
00:01:38.101 
00:01:38.571 [295.3MB/44.27s] Memory usage: 295.32MB (peak: 376.55MB), time: 44.27s

If composer update command exits != 0 the script would abort. Looks like composer exit 0 despite the failure. I guess one has to reproduce? The composer version we use is in integration/composer.git.

hashar closed this task as Resolved.Apr 17 2019, 1:32 PM
hashar claimed this task.

That is from two years ago. We have upgraded composer meanwhile and refactored the jobs a few times meanwhile.