Page MenuHomePhabricator

Split the backend savetiming metric into submetrics
Closed, ResolvedPublic

Description

Separate bots, API, etc. into their own submetrics.

Event Timeline

Gilles created this task.Sep 29 2017, 1:23 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 29 2017, 1:23 PM
Gilles triaged this task as High priority.Sep 29 2017, 1:23 PM
Gilles renamed this task from 2017-09-26 SaveTiming regression (backend only) to Split the backend savetiming metric into submetrics.Oct 4 2017, 7:12 PM
Gilles updated the task description. (Show Details)
Gilles updated the task description. (Show Details)
Gilles updated the task description. (Show Details)

Change 382750 had a related patch set uploaded (by Aaron Schulz; owner: Aaron Schulz):
[mediawiki/extensions/WikimediaEvents@master] Include save timing sub-metrics for better diagnostics

https://gerrit.wikimedia.org/r/382750

Change 382750 merged by jenkins-bot:
[mediawiki/extensions/WikimediaEvents@master] Include save timing sub-metrics for better diagnostics

https://gerrit.wikimedia.org/r/382750

Do we have dashboard for these new metrics yet?

aaron closed this task as Resolved.Oct 23 2017, 8:09 PM

They are on the main dashboard. If more or added, it would be good to split them out since the main save timing board is getting long.