Page MenuHomePhabricator

Universal Language Selector position (rtl/ltr)
Closed, ResolvedPublic

Description

The position of the Universal Language Selector (relative to the user toolbar) is the same for rtl and ltr user-interface language.

See (from Meta):

ltr -

rtl -

In my opinion, for rtl languages ULS link should be to the right of the user toolbar.

Event Timeline

Kaganer created this task.Oct 3 2017, 6:36 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 3 2017, 6:36 PM
Kaganer renamed this task from Universal Language Selector position to Universal Language Selector position (rtl/ltr).Oct 3 2017, 6:37 PM
Kaganer updated the task description. (Show Details)
Kaganer updated the task description. (Show Details)
Restricted Application added a project: I18n. · View Herald TranscriptOct 3 2017, 10:00 PM
Restricted Application added a subscriber: TerraCodes. · View Herald Transcript

@Kaganer: good first bug tasks are self-contained, non-controversial issues with a clear approach and should be well-described with pointers to help the new contributor. Given the current short task description I'm removing the good first bug tag. Please re-add the tag once the task description has been polished and provides sufficient information for a new contributor. Thanks!

Nikerabbit triaged this task as High priority.Oct 4 2017, 3:18 PM
Nikerabbit added projects: Regression, Vector.
Nikerabbit added subscribers: matmarex, Nikerabbit.

This used to work until recently. git bisect says that e951a09913c718ba894c581a4598b6976a92c3b9 is the first bad commit. CC @matmarex for advice.

matmarex claimed this task.Oct 4 2017, 4:36 PM

Presumably you have some workaround in place for the previous behavior (where the order of links in page HTML was reversed, T48947), similar to the one we have in VisualEditor (T50017). It should probably just be removed now.

Change 382187 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/skins/Vector@master] Do not special-case ULS and "Not logged in" in RTL in personal bar

https://gerrit.wikimedia.org/r/382187

Note that anonymous users may still see the issue after the fix is deployed for up to 14 days because of cached page renders. :/

Change 382187 merged by jenkins-bot:
[mediawiki/skins/Vector@master] Do not special-case ULS and "Not logged in" in RTL in personal bar

https://gerrit.wikimedia.org/r/382187

Change 382201 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/skins/Vector@wmf/1.31.0-wmf.1] Do not special-case ULS and "Not logged in" in RTL in personal bar

https://gerrit.wikimedia.org/r/382201

Change 382202 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/skins/Vector@wmf/1.31.0-wmf.2] Do not special-case ULS and "Not logged in" in RTL in personal bar

https://gerrit.wikimedia.org/r/382202

Change 382201 merged by jenkins-bot:
[mediawiki/skins/Vector@wmf/1.31.0-wmf.1] Do not special-case ULS and "Not logged in" in RTL in personal bar

https://gerrit.wikimedia.org/r/382201

Change 382202 merged by jenkins-bot:
[mediawiki/skins/Vector@wmf/1.31.0-wmf.2] Do not special-case ULS and "Not logged in" in RTL in personal bar

https://gerrit.wikimedia.org/r/382202

Stashbot added a subscriber: Stashbot.

Mentioned in SAL (#wikimedia-operations) [2017-10-04T18:22:04Z] <niharika29@tin> Synchronized php-1.31.0-wmf.1/skins/Vector/: Do not special-case ULS and Not logged in in RTL in personal bar T48947, T177312 (duration: 00m 51s)

Mentioned in SAL (#wikimedia-operations) [2017-10-04T18:23:13Z] <niharika29@tin> Synchronized php-1.31.0-wmf.2/skins/Vector/: Do not special-case ULS and Not logged in in RTL in personal bar T48947, T177312 (duration: 00m 50s)

matmarex closed this task as Resolved.Oct 4 2017, 6:24 PM
matmarex removed a project: Patch-For-Review.

Fixed and deployed.

Fixed and deployed.

Thanks!