Page MenuHomePhabricator

numerous images do not show.
Closed, DeclinedPublic

Description

seems to affect huge number of images - the one below is arbitrary one of them.
if this is a known/dupe, please close.
peace.

Details of the error are attached to the report, which will be publicly viewable. If you are not comfortable with that, you can edit the report below and remove all the data you don't want to share.

Error details:

error: could not load image from https://upload.wikimedia.org/wikipedia/commons/5/5e/Zsofia_Ildiko_Judit_ZsuZsa_1988_Thessaloniki.jpg
URL: https://commons.wikimedia.org/wiki/File:Zsofia_Ildiko_Judit_ZsuZsa_1988_Thessaloniki.jpg#/media/File:Zsofia_Ildiko_Judit_ZsuZsa_1988_Thessaloniki.jpg
user agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36
screen size: 1920x1080
canvas size: 1290x366
image size: 400x300
thumbnail size: CSS: 488x366, screen width: 488, real width: 800

Related Objects

Event Timeline

Kipod created this task.Oct 3 2017, 9:57 PM
Restricted Application added a project: Multimedia. · View Herald TranscriptOct 3 2017, 9:57 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Kipod triaged this task as Unbreak Now! priority.Oct 3 2017, 9:57 PM
Restricted Application added subscribers: Liuxinyu970226, Jay8g, TerraCodes. · View Herald TranscriptOct 3 2017, 9:57 PM
Aklapper lowered the priority of this task from Unbreak Now! to Needs Triage.EditedOct 3 2017, 10:16 PM

Resetting Unbreak now! priority as this has not been reproduced. See https://www.mediawiki.org/wiki/Phabricator/Project_management#Setting_task_priorities

https://upload.wikimedia.org/wikipedia/commons/5/5e/Zsofia_Ildiko_Judit_ZsuZsa_1988_Thessaloniki.jpg opens fine for me.

Has someone else also faced this problem? Same physical region?

Kipod triaged this task as Unbreak Now! priority.EditedOct 3 2017, 10:42 PM

reset priority to "unbreak now".

REPRODUCTION
in commons, click "random file"
more than 95% of images do not show. (need to click dozens of times to find an image that actually does show)

in the files that do not show, click "open in media viewer", and you get the "sorry, the file cannot be displayed. there seem to be a technical issue" page.

clicking any specific resolution (e.g., " 1,280 × 960 pixels "), gets you "an error occurred" screen :
https://upload.wikimedia.org/wikipedia/commons/thumb/a/a1/Dresdner_Stra%C3%9Fe%2C_Pirna_124122523.jpg/1280px-Dresdner_Stra%C3%9Fe%2C_Pirna_124122523.jpg

something seems to be broken - is it a ransomware attack?

peace.

Tgr lowered the priority of this task from Unbreak Now! to Needs Triage.Oct 3 2017, 10:53 PM
Tgr added a subscriber: Tgr.

Works for me. A network problem on your end is the most typical cause for this.

Kipod added a comment.Oct 3 2017, 11:10 PM

hmmmm.... never saw this behavior before. is it possible that a specific image server is misbehaving, and this is the one i'm hitting?

i have no problems getting images from any other (non-wikimedia) site, such as cnn/bbc/google etc., only mediawiki commons seems to be a problem.

peace.

Tgr added a comment.Oct 4 2017, 12:47 AM

Yes, or a specific cache server. But less likely than network issues on your end.
Do you see the image when opening directly? (The URL is shown on the error page.) Can you paste the response headers (you can check with curl -vso/dev/null <url> on Linux, or in your browser's network inspector) for an image that does not work?

Ramsey-WMF added a subscriber: Ramsey-WMF.

Possible similar/related to T175631: Image won't load?

Aklapper changed the task status from Open to Stalled.Oct 14 2017, 11:03 AM

Do you see the image when opening directly? (The URL is shown on the error page.) Can you paste the response headers (you can check with curl -vso/dev/null <url> on Linux, or in your browser's network inspector) for an image that does not work?

@Kipod: ^

Aklapper closed this task as Declined.Nov 6 2017, 10:54 AM

Unfortunately closing this report as no further information has been provided.

@Kipod: After you have provided the information asked for and if this still happens, please set the status of this report back to "Open" via the Add Action...Change Status dropdown. Thanks!

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptNov 6 2017, 10:54 AM