Page MenuHomePhabricator

flow-post-timestamp editedbefore RTL issue
Closed, ResolvedPublic

Description

in flow, under FF (not reproducible on chrome), the words "Edited" and "Before" are getting connected in RTL UI and LTR content.

Example: https://www.mediawiki.org/wiki/Topic:Tq4l6y2iw1jjd19w?uselang=he (the 4th comment in the thread)

Possible fixes:

  1. When explicitly stating dir=auto or RTL for flow-post-timestamp it looks OK.
  2. When .flow-timestamp span { direction:embed; } is changed to bidi-override also looks OK.

Details

Related Gerrit Patches:

Event Timeline

eranroz created this task.Oct 5 2017, 5:28 AM
Restricted Application added subscribers: TerraCodes, Aklapper. · View Herald Transcript

Unfortunately we can't use .flow-timestamp span { unicode-bidi: bidi-override; }, because then when viewing hewiki with my user language set to English, this happens:

However, it's not like it isn't already broken right now, it's just less bad:

Viewing an English-language wiki with ?uselang=he is broken in the same way:

Forcing the direction on .flow-timestamp span (similar dir="auto", but using CSS) fixes both the bug you reported, and these additional problems.

There was one additional problem, which meant I also had to force the direction AND set unicode-bidi: embed on .flow-post-timestamp:

Change 398891 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/Flow@master] Fix various bugs with timestamps in mixed directionality

https://gerrit.wikimedia.org/r/398891

Change 398891 merged by jenkins-bot:
[mediawiki/extensions/Flow@master] Fix various bugs with timestamps in mixed directionality

https://gerrit.wikimedia.org/r/398891

Checked in betalabs in hewiki and enwiki with uselang=he.
The following

<span datetime="1442618917000" class="flow-timestamp">
	<span class="flow-timestamp-user-formatted">18 בספטמבר 2015 16:28</span>
	<span id="jthdbeiioc" class="flow-timestamp-ago">לפני שנתיים</span>
</span>

will be displayed:

vs the current incorrect display:

Etonkovidova closed this task as Resolved.Dec 22 2017, 11:04 PM