Page MenuHomePhabricator

Handle {{refbegin}} ... {{refend}}
Closed, ResolvedPublic

Description

(Feature request) References added in a bulleted format within {{refbegin}} ... {{refend}} (as opposed to {{reflist}}) are left unanalyzed

E.g., the entire "Further reading" section was skipped in https://en.wikipedia.org/w/index.php?diff=prev&oldid=803879652

This includes most major articles, as refbegin/refend is common within dedicated bibliography sections

Event Timeline

czar created this task.Oct 5 2017, 7:09 AM
czar awarded a token.Oct 5 2017, 7:11 AM
Cyberpower678 triaged this task as Medium priority.Oct 6 2017, 9:11 PM
Cyberpower678 moved this task from Unsorted to New feature on the InternetArchiveBot (v1.6) board.
czar updated the task description. (Show Details)Apr 29 2018, 8:05 PM
czar added a comment.Apr 29 2018, 8:16 PM

Just wanted to reiterate again how crucial this is. Many article refs use this format instead of <ref> tags—especially on featured and {{sfn}}-heavy articles—so a big blind spot for iabot. (Not to mention the number of links not being preemptively archived.)

My current workaround is to temporarily put <ref> ... </ref> tags around the entire bibliography to get iabot to run on those citations, e.g., https://en.wikipedia.org/w/index.php?title=The_Democracy_Project&type=revision&diff=838867855&oldid=805207439

czar updated the task description. (Show Details)Dec 17 2018, 1:16 AM

Thanks for your patience. After rewriting the parsing engine and diligent testing, I can confirm this will be available in beta11.

https://en.wikipedia.org/w/index.php?title=The_Democracy_Project&diff=883185440&oldid=883185241

czar added a comment.EditedFeb 16 2019, 4:27 PM

This will be a game changer. Thank you!

Cyberpower678 closed this task as Resolved.Feb 23 2019, 3:05 AM
czar reopened this task as Open.Jun 15 2019, 7:47 PM
This comment was removed by czar.
czar closed this task as Resolved.Jun 15 2019, 7:49 PM

@Cyberpower678 do you have an estimate on when this will be deployed?

Looks like this is still happening (example)