Page MenuHomePhabricator

Using Live Update, an unseen page opened in a new tab is not marked as seen on Watchlist
Closed, InvalidPublic

Description

Initial report

User case:

  1. open Watchlist and enable Live Update
  2. open an unseen revision in a new tab
  3. close that tab

Expectation: the reviewed page is marked as seen by Live Update a few time after the page has been seen
Reality: the reviewed page is not marked as seen by Live Update until a new revision pops-in Watchlist results.

How to reproduce the reality:

  1. open Watchlist and enable Live Updates
  2. open an unseen revision in a new tab
  3. close that tab
  4. open a page listed in the watchlist in a new tab
  5. edit the page and close the tab

Result:

  • the edited page appears as unseen in Watchlist results
  • the unseen revision is marked as seen

@SBisson what do you think of updating seen changes without any new entry coming? Isn't it a bit performance consuming?

Event Timeline

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptOct 5 2017, 8:51 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
IKhitron added a comment.EditedOct 5 2017, 12:36 PM

Hi. Thanks for the ticket. As I already said, describing the case, I do not know if it's a bug or done in purpose. But anyway, it should be either fixed, or clearly documented on the help page, so users will not expect for nothing such a behaviour. Thank you.

Live update works by periodically asking the server if there are changes newer than the top entry currently shown on the list. That's also expressed visually by fading in new lines and having a separator between old and new.

Trying to detect changes to old entries in general could be challenging but I think there is a simple solution specifically for the seen/unseen case. It would be a feature, not a quick fix, but it's doable.


Technical note:
When we process peek=1, we could check if the current filters with wl_timestamp > from instead of rc_timestamp > from return anything.

I want to make sure I'm understanding the issue here. The problem is that the page does not know that a change has been seen until you reload the page. Is that correct?

If so, I just want to point out that this has always been the case on Watchlist.

So this is a request for a new feature, such that Live Update would go back and update old tasks as well as adding the newer tasks to the list. Again, do I have that right?

Finally, @SBisson seems to have an idea of how to do this. But I have a question re. that: One of the good things about the way Live Update works is that it's quick, because it's only finding what's new. If you had to re-review the status of everything else on the page, wouldn't this whole process slow down? Also, can you please comment on how difficult you think this might be?

I want to make sure I'm understanding the issue here. The problem is that the page does not know that a change has been seen until you reload the page. Is that correct?

Not so long, just until the next live update.

If so, I just want to point out that this has always been the case on Watchlist.

Because nothing was changed on Watchlist until now, including this.

So this is a request for a new feature, such that Live Update would go back and update old tasks as well as adding the newer tasks to the list. Again, do I have that right?

No, it is not a request. I asked how it should work, and not asked to implement this anyway.

! In T177461#3689141, @IKhitron wrote:

...No, it is not a request. I asked how it should work, and not asked to implement this anyway.

Oh. Thanks for clarifying IKhitron. Have we answered your question? Can I close this, then?

! In T177461#3689141, @IKhitron wrote:

...No, it is not a request. I asked how it should work, and not asked to implement this anyway.

Oh. Thanks for clarifying IKhitron. Have we answered your question? Can I close this, then?

So, what is the answer? I saw one post about how to fix that, and your post that claims at the opposite that should be like that, because of something I believe isn't so right, as I already explained in the second part of my previous post.

@IKhitron, I guess you want us to implement a way to update the RCs/Watchlist when a page you watch is visited in a different tab? I'm asking, ecaise you are saying we don't need to implement it on that comment:

I asked how it should work, and not asked to implement this anyway.

@IKhitron, I guess you want us to implement a way to update the RCs/Watchlist when a page you watch is visited in a different tab? I'm asking, ecaise you are saying we don't need to implement it on that comment:

I asked how it should work, and not asked to implement this anyway.

No, I don't. I just wanted to get an answer, one of two options: It will be fixed for sure very soon, or it was documented in help page that this feature does not exist, that's all. Thank you.

Aklapper closed this task as Invalid.Oct 17 2017, 6:53 PM

Answered already in T177461#3660568: "Trying to detect changes to old entries [...] would be a feature."
Hence current behavior is as expected.

In T177461#3689141 the reporter wrote "No, it is not a request."
Hence nothing is wanted in this task. Hence closing task as invalid.

And if someone really wants to document features which do not exist, I won't stop anyone from doing that.

Thank you for the answer. I still think it should be documented.