Page MenuHomePhabricator

AuthorityControl doesn't provide links to non-files on Commons and coordinates anymore
Closed, ResolvedPublic

Description

As reported on project chat and "contact the developers", statements as https://www.wikidata.org/wiki/Q2013#P373 don't have links anymore. This used to be the case till this weeks deploy AFAIK. JavaScript console is not showing relevant information.

Event Timeline

Restricted Application added a project: Wikidata. · View Herald TranscriptOct 7 2017, 2:54 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

@Lucas_Werkmeister_WMDE I think you worked on some things related to the snakview, do you think this affected the gadget?

My changes just added some extra classes, e. g. wikibase-snakview-c486e6d62b2f2c2330e0973b40c49ae412b41d9f in this case (in addition to the existing wikibase-snakview). I don’t think this should have affected the gadget.

If I copy the gadget code from MediaWiki:Gadget-AuthorityControl.js and run it from Firefox’ Scratchpad (Shift+F4), it works, so perhaps it’s a problem related to initialization order?

Sjoerddebruin moved this task from Backlog to Bugs on the Wikidata-Gadgets board.Oct 7 2017, 9:22 PM
Robby added a subscriber: Robby.Oct 8 2017, 6:30 AM
Ayack added a subscriber: Ayack.Oct 8 2017, 4:50 PM

Hello, any progress on this issue? Not having a link for geocoordinates is really annoying. Thanks.

Sjoerddebruin renamed this task from AuthorityControl doesn't provide links to non-files on Commons anymore to AuthorityControl doesn't provide links to non-files on Commons and coordinates anymore.Oct 26 2017, 10:29 AM
Sjoerddebruin triaged this task as High priority.

Purging sometimes makes the coordinates links reappear, but sometimes they are linked and purging does the opposite.

Jarekt added a subscriber: Jarekt.Nov 1 2017, 4:17 PM

I reported this issue on Wikidata:Project_chat. I have no idea why AuthorityControl.js would be related to links to Commons. I thought it only does links for identifiers and coordinates. I have problems with Commons category (P373) and Commons creator (P1472). Usually it took a long time for those links to show up, like it was last on initialization order, and if it did not show up than reloading the page usually worked. But now for many items it does not work no matter how many times you reload or how long you wait. Although in some cases after you add some new statement to some other property than the link would show up.

Ayack awarded a token.Nov 3 2017, 3:46 PM

Is this task still relevant? On https://www.wikidata.org/wiki/Q2013#P373 I can only reproduce it sporadically when repeatedly reloading the page – most of the time the gadget seems to work.

most of the time the gadget seems to work.

For me, it doesn't work most of the time (it does sometimes, though).

I just opened 10 random pages with P373 and they all did not have links. The same issue with: Commons Creator page (P1472), Commons gallery (P935), Commons Institution page (P1612), etc. It is a major issue for those maintaining those properties. I do not know why a javascript would be tasked with providing interwiki links. Maybe the issue is that those properties should not use "catch-all" string type and use data-type designed for interwiki links. See my T179937 proposal to "Add a new Wikidata datatype for linking to Commons pages or expand ''Commons media file'' type".

Instead of fixing the gadget it would be more elegant if T192188 could be resolved.

Nikki added a comment.Jul 13 2018, 2:12 PM

Lucas should get the credit for doing T189599, I just added it to the gadget after he told me about it. :)

Sjoerddebruin closed this task as Resolved.Jul 13 2018, 2:13 PM
Sjoerddebruin assigned this task to Nikki.

Can confirm that this is fixed, thank you very much!