Page MenuHomePhabricator

Align Notifications/Echo to WikimediaUI color palette
Closed, ResolvedPublic

Description

Align all colors to overhauled WikimediaUI color palette.

Event Timeline

Volker_E created this task.Oct 8 2017, 4:45 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptOct 8 2017, 4:45 PM

Change 383016 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/extensions/Echo@master] Replacing fallback color for code hygiene

https://gerrit.wikimedia.org/r/383016

Change 383021 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/extensions/Echo@master] Align popup message color to toast message in MinervaNeue

https://gerrit.wikimedia.org/r/383021

Change 383036 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/extensions/Echo@master] Fix CrossWiki-/BundleGroup layout

https://gerrit.wikimedia.org/r/383036

Before 383036After

@Pginer-WMF Replacing NotificationItemWidget's background-color from currently #f1f1f1 with #f8f9fa would result in a somewhat dissatisfying:


The footer buttons are not clearly distinct from the items. Ideas?

Change 383037 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/extensions/Echo@master] Replace subtle greys with WikimediaUI color palette ones

https://gerrit.wikimedia.org/r/383037

Before 383036After

The before/after comparison shows another change apart from color. When expanding a bundle, part of the parent bundle is shown after its contents to emphasise that those are shown inside. This white stripe seems to be gone with the change.

Change 383037 merged by jenkins-bot:
[mediawiki/extensions/Echo@master] Replace subtle greys with WikimediaUI color palette ones

https://gerrit.wikimedia.org/r/383037

Change 383021 merged by jenkins-bot:
[mediawiki/extensions/Echo@master] Align popup message color to toast message in MinervaNeue

https://gerrit.wikimedia.org/r/383021

@Pginer-WMF Sorry, yes, that white area via margin-bottom is back in.

Change 383036 merged by jenkins-bot:
[mediawiki/extensions/Echo@master] Fix CrossWiki-/BundleGroup layout

https://gerrit.wikimedia.org/r/383036

Volker_E closed this task as Resolved.Oct 17 2017, 1:45 AM
Volker_E removed a project: Patch-For-Review.
Volker_E removed a subscriber: gerritbot.
Volker_E reopened this task as Open.Oct 17 2017, 3:20 AM

Checked in betalabs and wmf.6 - the white stripe is present for bundled notifications. However, there is a slight visual difference (quite minor) between cross-wiki bundled notifications and the same wiki notifications bundle.
cross-wiki bundle

the same wiki bundled notifications

If @Pginer-WMF regarding the above - should it be adjusted?

If @Pginer-WMF regarding the above - should it be adjusted?

It would be nice to be the same, but I'm more concerned about the padding around the bundled elements. There the top padding seems much smaller than the padding on the other sides. I marked top and bottom paddings in red and blue to illustrate the issue:

I think the space was better balanced before, so I'm not sure what has introduced this regression.

I think it is not as clear that those elements are sub-elements while there is too much going (borders, backgrounds, box-shadows, double margins) on to visualize that parent>child idea.

Change 390299 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/extensions/Echo@master] Equal CrossWiki/BundleNotificationItemWidget group's padding

https://gerrit.wikimedia.org/r/390299

Change 390299 merged by jenkins-bot:
[mediawiki/extensions/Echo@master] Equal CrossWiki/BundleNotificationItemWidget group's padding

https://gerrit.wikimedia.org/r/390299

Checked in betalabs - the padding is equalized.

The remaining pieces here are a fallback color handled in https://gerrit.wikimedia.org/r/#/c/383016/ and the question about read notifications handled in T78594.

Change 383016 merged by jenkins-bot:
[mediawiki/extensions/Echo@master] Replacing fallback color for code hygiene

https://gerrit.wikimedia.org/r/383016

Volker_E closed this task as Resolved.Jun 6 2018, 6:51 PM
Volker_E removed a project: Patch-For-Review.