Page MenuHomePhabricator

Merge Cite icons into OOUI
Closed, ResolvedPublic

Description

Cite currently uses the following icons:

Also used in Citoid:

OOUI has a few icons but there are no known uses of them:

Event Timeline

Esanders created this task.Oct 10 2017, 3:09 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 10 2017, 3:09 PM
Izno moved this task from Unsorted backlog to External on the Cite board.Oct 18 2017, 1:06 PM

@Esanders Maybe as 'editing-citations' pack? Would that make sense from your POV?

Volker_E triaged this task as Low priority.Dec 22 2017, 10:25 PM
Volker_E moved this task from Backlog to Next-up on the OOUI board.Feb 2 2018, 2:13 AM
Esanders updated the task description. (Show Details)Apr 6 2018, 12:22 PM

Sounds good. The icon set in Cite seems more homogeneous at the moment.

Volker_E added a comment.EditedMay 8 2018, 12:30 AM

@Esanders Do you also want to move

  • citeArticle,
  • book,
  • journal and
  • newspaper

over to that pack?

Change 431684 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[oojs/ui@master] icons: Add 'editing-citation' pack

https://gerrit.wikimedia.org/r/431684

Change 431684 merged by jenkins-bot:
[oojs/ui@master] icons: Add 'editing-citation' pack

https://gerrit.wikimedia.org/r/431684

@Esanders Do you also want to move

  • citeArticle,
  • book,
  • journal and
  • newspaper

over to that pack?

Yes, upstreaming them from the Cite extension ( https://gerrit.wikimedia.org/r/plugins/gitiles/mediawiki/extensions/Cite/+/master/modules/ve-cite/icons/ ) would be good…

That's partly what happened in above patch, when newly designed icons by Design team weren't available. We'll update integrated Cite icons ('referenceExisting', 'references', 'web') accordingly to icon design principles.

RHo added a subscriber: RHo.May 9 2018, 1:21 PM
RHo added a comment.May 14 2018, 5:39 PM

Proposal for the 3 updated icons (web, existing reference, references):

@RHo Thanks for the update!
A few notes:

  • Reference and References RTL are probably not necessary and opposing our approaches with other similar icons as the bookmark is a right-hand and not RTL first thing in my understanding. We currently don't feature reference-rtl.
  • Website: Option 2, 'browser' is my preference, as window represents web context less strongly
  • References: in the one with book and reference icon, there's a lot going on in that icon. Although I understand the idea, I'm not sure it's working well as icon. On the other hand we are not building a clear visual connection between references and reference. Are books/library metaphor sufficient? I lean towards, yes.

From today's design meeting:

  • @RHo identified that having both, 'reference' & 'quotes' in similar functionality might not be useful. Unclarity about how “quotations” icon for triggering citations dialog came into place. Reference is only used for basic form option of citations dialog in all of our codebase. Also, the quotations symbol is used in other editor context as blockquote icon. @Esanders, any historic insights?

New proposal with a few more options:

Per design review meeting with comments from @Volker @Pginer-WMF :

  • Website icon - slight preference for option 1 since there it is more generic to not have the window bar icon on the LHS, and does not need a separate RTL version
  • Reference icon - my preference is for option 3 which takes the existing cite icon used in VE but the additional brackets relates it back to "[ citation needed ]" and the square brackets used on references. + @Nirzar if you have any comments from working on VE before about this icon's recognizability, etc? This usability study mentions a participant thinking that the cite icon (on the wikitext toolbar) meant bookmark so perhaps there is something to not reusing the bookmark icon here...
  • ReferenceS icon - my preference is for option 3, or option 4 (perhaps simplified further)
  • Existing reference icon - would ideally like to not need a separate icon for Existing reference, so option 3 again

Incidentally @Volker_E - the wikitext toolbar is currently using the book icon instead of reference - should the correction be done as part of this ticket or a separate one?

@RHo For the last point on wikitext 2010 editor, that needs to be filed in a separate ticket.

Volker_E moved this task from Next-up to Doing on the OOUI board.Jun 4 2018, 7:48 PM

Follow-up for WikiEditor 'reference' icon at T202463.

Volker_E closed this task as Resolved.Aug 21 2018, 10:43 PM
Volker_E assigned this task to Jdforrester-WMF.

Original task has been resolved. https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/Cite/+/452736/ was the step of using 'editing-citation' pack.

Volker_E removed a subscriber: gerritbot.