Page MenuHomePhabricator

Can not unblock / remove autoblocks on Special:Unblock, because user input tool doesn't recognise autoblocks
Closed, ResolvedPublic

Description

Trying to remove an autoblock eg. https://en.wikipedia.org/w/index.php?title=Special:Unblock&wpTarget=%237892601 doesn't work, it's rejected as an invalid username.

Caused by f524623d, sadly.

Event Timeline

Addshore created this task.Oct 11 2017, 3:14 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 11 2017, 3:14 PM
Addshore triaged this task as High priority.Oct 11 2017, 3:14 PM
Addshore updated the task description. (Show Details)
Addshore added a subscriber: DoRD.

Change 383596 had a related patch set uploaded (by Ladsgroup; owner: Amir Sarabadani):
[mediawiki/core@master] Fix unblocking autoblocks

https://gerrit.wikimedia.org/r/383596

Restricted Application added a project: User-Ladsgroup. · View Herald TranscriptOct 11 2017, 3:20 PM

Change 383596 merged by jenkins-bot:
[mediawiki/core@master] Fix unblocking autoblocks

https://gerrit.wikimedia.org/r/383596

Change 383634 had a related patch set uploaded (by Ladsgroup; owner: Amir Sarabadani):
[mediawiki/core@wmf/1.31.0-wmf.3] Fix unblocking autoblocks

https://gerrit.wikimedia.org/r/383634

Change 383635 had a related patch set uploaded (by Ladsgroup; owner: Amir Sarabadani):
[mediawiki/core@wmf/1.31.0-wmf.2] Fix unblocking autoblocks

https://gerrit.wikimedia.org/r/383635

Change 383635 merged by jenkins-bot:
[mediawiki/core@wmf/1.31.0-wmf.2] Fix unblocking autoblocks

https://gerrit.wikimedia.org/r/383635

Change 383634 merged by jenkins-bot:
[mediawiki/core@wmf/1.31.0-wmf.3] Fix unblocking autoblocks

https://gerrit.wikimedia.org/r/383634

Mentioned in SAL (#wikimedia-operations) [2017-10-11T23:17:47Z] <thcipriani@tin> Synchronized php-1.31.0-wmf.3/includes/specials/SpecialUnblock.php: SWAT: [[gerrit:383634|Fix unblocking autoblocks]] T177952 (duration: 00m 51s)

Jdforrester-WMF renamed this task from Can not unblock / remove autoblocks to Can not unblock / remove autoblocks on Special:Unblock, because user input tool doesn't recognise autoblocks.Oct 11 2017, 11:18 PM
Jdforrester-WMF removed a project: Patch-For-Review.
Jdforrester-WMF updated the task description. (Show Details)

Mentioned in SAL (#wikimedia-operations) [2017-10-11T23:19:07Z] <thcipriani@tin> Synchronized php-1.31.0-wmf.2/includes/specials/SpecialUnblock.php: SWAT: [[gerrit:383635|Fix unblocking autoblocks]] T177952 (duration: 00m 50s)

Jdforrester-WMF closed this task as Resolved.Oct 11 2017, 11:20 PM

Revert now deployed to both production branches.