Page MenuHomePhabricator

Upgrade LVS servers to stretch
Closed, ResolvedPublic

Description

We want to upgrade all LVS servers to stretch for multiple good reasons, including T171850 and the fact that it's the right thing to do. :-)

The process should be relatively straightforward. A couple of things to keep in mind:

  • We need to have pybal in stretch-wikimedia
  • There's no libnagios-plugin-perl in stretch, so we should get rid of the require in pybal::monitoring and rewrite /usr/local/lib/nagios/plugins/check_pybal

Details

Related Gerrit Patches:

Event Timeline

ema created this task.Oct 11 2017, 4:07 PM
Restricted Application added a project: Operations. · View Herald TranscriptOct 11 2017, 4:07 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
ema triaged this task as Medium priority.Oct 11 2017, 4:09 PM
ema updated the task description. (Show Details)
BBlack added a subscriber: BBlack.Oct 11 2017, 4:27 PM

One significant thing to keep in mind is the interface naming changes. We'll be going from e.g. eth[0-3] to something like eno[1-2], ens1f[0-1], and we'll have to work that into all the magic that's configuring our per-vlan interfaces and doing all the custom network setup stuff, etc. Some of it could be easy to miss (breaks "silently", at least to some level of testing/scrutiny).

Change 383834 had a related patch set uploaded (by Ema; owner: Ema):
[operations/puppet@production] pybal: use Monitoring::Plugin in check_pybal

https://gerrit.wikimedia.org/r/383834

Change 383834 merged by Ema:
[operations/puppet@production] pybal: use Monitoring::Plugin in check_pybal

https://gerrit.wikimedia.org/r/383834

ema moved this task from Triage to LoadBalancer on the Traffic board.Oct 13 2017, 2:28 PM

Change 423699 had a related patch set uploaded (by Vgutierrez; owner: Vgutierrez):
[operations/debs/pybal@1.15-stretch] Release 1.15.3: Avoid having a hard requirement on prometheus-client

https://gerrit.wikimedia.org/r/423699

Change 423699 merged by Vgutierrez:
[operations/debs/pybal@1.15-stretch] Release 1.15.3: Avoid having a hard requirement on prometheus-client

https://gerrit.wikimedia.org/r/423699

Change 425040 had a related patch set uploaded (by Vgutierrez; owner: Vgutierrez):
[operations/puppet@production] lvs: Get rid of interface names on site.pp

https://gerrit.wikimedia.org/r/425040

Mentioned in SAL (#wikimedia-operations) [2018-04-10T13:51:36Z] <vgutierrez> disable puppet on primary LVS to merge safely gerrit/425040 T177961

Change 425040 merged by Vgutierrez:
[operations/puppet@production] lvs: Get rid of interface names on site.pp

https://gerrit.wikimedia.org/r/425040

Change 425782 had a related patch set uploaded (by Ema; owner: Ema):
[operations/puppet@production] pybal::monitoring: install libwww-perl

https://gerrit.wikimedia.org/r/425782

Change 425782 merged by Ema:
[operations/puppet@production] pybal::monitoring: install libwww-perl

https://gerrit.wikimedia.org/r/425782

Vgutierrez changed the status of subtask T190993: Upgrade pybal-test instances to stretch from Open to Stalled.Apr 12 2018, 1:32 PM
mark moved this task from Backlog to In Progress on the Pybal board.Jul 11 2018, 2:46 PM
MoritzMuehlenhoff closed this task as Resolved.Jul 8 2019, 10:53 AM
MoritzMuehlenhoff claimed this task.

With the recent replacement of lvs100*, all LVS servers are running Stretch.