Page MenuHomePhabricator

pagetranslation log_type missing on replicas
Closed, ResolvedPublic

Description

pagetranslation log_type is no longer replicated/available in the replicated db's:

MariaDB [commonswiki_p]> SELECT DISTINCT log_type from logging;
+-------------+
| log_type    |
+-------------+
| abusefilter |
| block       |
| delete      |
| gblblock    |
| gblrights   |
| globalauth  |
| import      |
| lock        |
| managetags  |
| massmessage |
| merge       |
| move        |
| newusers    |
| patrol      |
| protect     |
| renameuser  |
| rights      |
| thanks      |
| upload      |
+-------------+
19 rows in set (0.46 sec)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 12 2017, 9:38 AM
Andrew added a subscriber: Andrew.Oct 12 2017, 2:14 PM

It looks to me like this is filter in maintain-views.yaml via logging_whitelist. However, I don't see that 'pagetranslation' has ever been in that list (or at least not since 2016-10-12 which is when the history becomes murky.)

Can you confirm that you think this is a regression and not a feature request? If it's a regression do you know when it was last available?

It looks to me like this is filter in maintain-views.yaml via logging_whitelist. However, I don't see that 'pagetranslation' has ever been in that list (or at least not since 2016-10-12 which is when the history becomes murky.)

Can you confirm that you think this is a regression and not a feature request? If it's a regression do you know when it was last available?

Simone reported to me that the TA counter tool is broken a few weeks ago. Today i had time to do some verifications, i found out that the data is no longer replicated and was unable to find anything on announcement lists & phabricator tasks. The data is no longer replicated since 4 July 2017

bd808 edited projects, added Data-Services; removed Tools.Oct 12 2017, 10:24 PM
bd808 added a subscriber: bd808.Oct 12 2017, 10:36 PM

There are quite a few filtered out compared to the raw production wikidb:

(wikiadmin@db1091) [commonswiki]> SELECT DISTINCT log_type from logging;
+-------------------+
| log_type          |
+-------------------+
| abusefilter       |
| block             |
| contentmodel      |
| delete            |
| gblblock          |
| gblrights         |
| globalauth        |
| gwtoolset         |
| import            |
| lock              |
| managetags        |
| massmessage       |
| merge             |
| move              |
| newusers          |
| notifytranslators |
| pagelang          |
| pagetranslation   |
| patrol            |
| protect           |
| renameuser        |
| rights            |
| spamblacklist     |
| suppress          |
| tag               |
| thanks            |
| timedmediahandler |
| translationreview |
| upload            |
| usermerge         |
+-------------------+
30 rows in set (0.00 sec)

The reported date roughly lines up with this SAL entry:
2017-07-03 16:55 <bd808> Running maintain-views --all-databases --clean --replace-all --debug on labsdb1001

bd808 added a subscriber: Bawolff.

The current whitelist does not allow the pagetranslation log_type. It sounds like this type was allowed under some previous filtering scheme and then stopped being available when I force synced the views with the current configuration.

If we can get someone like @Bawolff to sign off on it being ok we can get it added to the list. It would be nice to add all of the ok to show types from the list I captured in T178052#3681534 at once.

Marostegui added a subscriber: Marostegui.

Just for the record, those are replicated on the labs hosts, they are just missing the views:

mysql:root@localhost [commonswiki]> select @@hostname;
+------------+
| @@hostname |
+------------+
| labsdb1009 |
+------------+
1 row in set (0.00 sec)

mysql:root@localhost [commonswiki]> SELECT DISTINCT log_type from logging;
+-------------------+
| log_type          |
+-------------------+
| abusefilter       |
| block             |
| contentmodel      |
| delete            |
| gblblock          |
| gblrights         |
| globalauth        |
| gwtoolset         |
| import            |
| lock              |
| managetags        |
| massmessage       |
| merge             |
| move              |
| newusers          |
| notifytranslators |
| pagelang          |
| pagetranslation   |
| patrol            |
| protect           |
| renameuser        |
| rights            |
| spamblacklist     |
| suppress          |
| tag               |
| thanks            |
| timedmediahandler |
| translationreview |
| upload            |
| usermerge         |
+-------------------+

If Security is fine with this additions, we are also fine :-)

Ok, so suppress, spamblacklist and titleblacklist must not be in the view.

Other than those three, all the one's listed at T178052#3681534 are fine to add to the log type whitelist.

Change 384201 had a related patch set uploaded (by BryanDavis; owner: Bryan Davis):
[operations/puppet@production] maintain-views: Add log types to logging_whitelist

https://gerrit.wikimedia.org/r/384201

bd808 moved this task from Backlog to Wiki replicas on the Data-Services board.Oct 16 2017, 4:49 AM

Change 384201 merged by Andrew Bogott:
[operations/puppet@production] maintain-views: Add log types to logging_whitelist

https://gerrit.wikimedia.org/r/384201

Andrew closed this task as Resolved.Oct 16 2017, 3:18 PM
Andrew claimed this task.

All set.