Page MenuHomePhabricator

Edit Counter: Request for year and month counts to be displayable in a table for screen reader users
Closed, ResolvedPublic

Description

As a screen reader user, I'dI can't access the charts of the year and month counts in the edit counter, and the tables seem to have disappeared. I would like them to return, or there should at least be an option for displaying them in the original table format.

XTools version: 3.1.12-ab399de

Event Timeline

MusikAnimal moved this task from Inbox to Other on the XTools board.Oct 12 2017, 4:03 PM
MusikAnimal added a subscriber: MusikAnimal.

Sorry about that! It looks like the chart library we're using doesn't have accessibility support built-in, but we will try to add support by other means.

We also want to add tables with the data for users who do not have JavaScript enabled (T175661). This does not necessarily help those with screen readers, however. So the issue is we don't want to have to duplicate the content twice (in addition to the charts). So what I think we should do is put the tables with the counts in <noscript> as planned for T175661, and then using JavaScript copy it outside the <noscript> tag, and position it off-screen. This should effectively make it screen-readable and we only need to build the markup in one place within our code.

We admittedly have not done a good job at adding accessibility attributes, such as the aria roles. We will have to look into this as well.

The new wikitext option in the edit counter kinda resolves this for me; I can preview the result in my sandbox and it works fine ... I can even access the timecards now! If a text-only option was added that basically provided a more user-friendly way to do that, I'd say the bug would be completely resolved.

MusikAnimal claimed this task.EditedFeb 14 2018, 1:12 AM
MusikAnimal moved this task from Other to Working on the XTools board.

The new wikitext option in the edit counter kinda resolves this for me; I can preview the result in my sandbox and it works fine ... I can even access the timecards now! If a text-only option was added that basically provided a more user-friendly way to do that, I'd say the bug would be completely resolved.

That's crazy talk! We will add better screen reader support. You should not have to jump through all these hoops just to get some numbers. I'm sorry we haven't prioritized accessibility. It's important, and you're definitely not the only one who would benefit from it.

I'm going to get started on this now. I've actually learned about some new tactics to improve accessibility, so it may not be as hard as I thought.

Would you mind sharing what software you use as a screen reader? That way I can test it and make sure everything is readable.

Thanks very much. The screen reader I use is JAWS.

@Graham87 When you get a chance, please confirm you can access the year counts, month counts, and timecard. Example: https://xtools.wmflabs.org/ec/en.wikipedia.org/L235

I went through all the other tools in the XTools suite, and I didn't find anything that isn't shown in plain text, so you should be able to access everything. If something does seem off, just let us know :) We foolishly have not been using ARIA, a web technology that improves accessibility. However I think our current UI design may mean we don't necessarily need them (correct me if I'm wrong!).

And again, sorry it took so long to fix this!

MusikAnimal moved this task from Working to Pending Review on the XTools board.Feb 19 2018, 10:29 PM

Thanks very much; they work! I would slightly prefer if the month/year counts were displayed in an HTML table rather than a div (especially the month counts), so I could navigate up an down the data more easily. The only other accessibility-related problem I've noticed is I can't read what I've found out is a tooltip (through the HTML source) just above the listing for the number of articles created.

I don't know much about ARIA ... I'm a bit old-school that way ... but I don't think we'll need it here.

Thanks again for your help here!

@Graham87 Alright, I've got an update on our staging server, let me know how this works: https://xtools-dev.wmflabs.org/ec/en.wikipedia.org/L235

The month and year counts are now a table. I don't have Windows, so I've been using a Chrome extension to test screen reader support rather than JAWS. I'm not able to navigate through the tables, but maybe you are?

For the tooltips, I am using ARIA which seems to work with my screen reader. Hopefully it does for you too. There are two other tooltips on the initial form if you want to test those, try it at https://xtools-dev.wmflabs.org/ec

Though to be honest the tooltip for the Username is a lie. It doesn't actually work for IPs... but I will fix that soon, ha.

Thanks, the tables sound good.

Re the tooltips: I didn't communicate very clearly; what I meant was that JAWS said some extraneous text that turned out to be a tooltip ... it says "tools/editcounter"above the pages created element. Tooltips don't actually work very well at all with JAWS ... see this document that I found about it's ARIA support:
https://www.freedomscientific.com/Content/Documents/Other/JAWS-ARIA-Support.doc

But on a scale of 1 to 10, I'd rate the importance of this issue about a two.

MusikAnimal closed this task as Resolved.Feb 21 2018, 6:51 PM
MusikAnimal moved this task from Pending Review to Complete on the XTools board.

Glad to hear the feedback is (mostly) good! :) I've deployed these changes.

I'm going to go ahead and close this, but I will look into your issue with the tooltip more at a later time.

I'd like to thank you once more for reaching out to us about the lack of screen reader support. Accessibility is supposed to be an natural tendency for web developers, but we (myself especially) have failed to give it much attention. You have opened my eyes (no pun intended) to this issue. I've learned more about how to improve accessibility, and look forward to better supporting it in future projects of mine.