Page MenuHomePhabricator

Create and initialise the main and deploy repositories
Closed, ResolvedPublic2 Estimate Story Points

Description

Per wt:Services/FirstDeployment#Repositories, we need to create main and deploy repositories for the headless Chromium based render service.

AC

  • Create the mediawiki/services/chromium-render repository
  • Create the mediawiki/services/chromium-render/deploy repository

The above two items are confirmed as done in T178071#3683040.

There are some large files that cannot be pushed to gerrit (see the description of T178189). Make sure to ignore them. See T178189#3691105.

@phuedx: This AC is moot since we decided to use the Debian Stretch version of Chromium (see the following AC and T181084: [EPIC] Deploy the mediawiki-services-chromium-render service (Proton) for a summary and links to tasks that provide more detail).

  • Make sure puppeteer doesn't download its own version of chromium. From the operations point of view, using the Debian Stretch version makes more sense. See T178189#3692824. See documentation on how to skip downloading Chromium.

@phuedx: This is done by design.

Details

Related Gerrit Patches:
operations/puppet : productionNew: add chromium_render service

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
Restricted Application added subscribers: TerraCodes, Aklapper. · View Herald TranscriptOct 13 2017, 2:02 PM
phuedx updated the task description. (Show Details)Oct 13 2017, 2:03 PM
phuedx updated the task description. (Show Details)Oct 13 2017, 2:06 PM

AFAIK git push requires special permissions, hence this task is not good first task

The change's ready but cannot push it to gerrit due to T178189: [spike] Temporarily allow pushing large objects.

ovasileva triaged this task as High priority.Oct 16 2017, 10:19 AM
ovasileva moved this task from Upcoming to 2017-18 Q2 on the Readers-Web-Backlog board.
ovasileva set the point value for this task to 3.Oct 17 2017, 4:51 PM
ovasileva moved this task from 2017-18 Q2 to Upcoming on the Readers-Web-Backlog board.
ovasileva added a subscriber: ovasileva.

moving back to upcoming on the backlog, as we're not expecting to begin this work in this sprint

bmansurov removed bmansurov as the assignee of this task.Nov 15 2017, 8:43 PM
phuedx updated the task description. (Show Details)Nov 29 2017, 6:15 PM
MBinder_WMF changed the point value for this task from 3 to 2.Nov 29 2017, 6:45 PM
ovasileva moved this task from Triage to Current Sprint on the Proton board.Dec 1 2017, 2:37 PM
Niedzielski added a subscriber: Niedzielski.

I'm claiming this as it's very related to the other service stand up work.

Change 409996 had a related patch set uploaded (by Niedzielski; owner: Stephen Niedzielski):
[operations/puppet@production] New: add chromium_render service

https://gerrit.wikimedia.org/r/409996

phuedx changed the task status from Open to Stalled.Mar 7 2018, 4:09 PM
phuedx moved this task from 2017-18 Q3 to Triaged but Future on the Readers-Web-Backlog board.
Niedzielski removed Niedzielski as the assignee of this task.Mar 7 2018, 4:10 PM

Change 409996 abandoned by Niedzielski:
New: add chromium_render service

Reason:
Abandoned until next quarter.

https://gerrit.wikimedia.org/r/409996

Change 409996 restored by Niedzielski:
New: add chromium_render service

https://gerrit.wikimedia.org/r/409996

Change 409996 abandoned by Niedzielski:
New: add chromium_render service

Reason:
Superseded by Id227c1e597f999097093c1f17e97e02eee7b17df

https://gerrit.wikimedia.org/r/409996

Is this still stalled @phuedx and @pmiazga ? If so, any updates?

phuedx updated the task description. (Show Details)Jul 27 2018, 11:02 AM
phuedx updated the task description. (Show Details)
phuedx closed this task as Resolved.Jul 27 2018, 11:05 AM
phuedx claimed this task.

All the AC have been met 🎉🎉🎉