Page MenuHomePhabricator

Tours are broken: TypeError
Closed, ResolvedPublic

Description

The tours on https://www.wikidata.org/wiki/Wikidata:Tours don't work anymore. There is nothing showing up after selecting the arrow in the first window. The JavaScript console is showing the following:

TypeError: Attempted to assign to readonly property.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 14 2017, 2:59 PM

The problem is related to overlays. I removed the overlays from the tours, now they are working again for the time being, but with a worse graphics.

Mrjohncummings added a comment.EditedOct 15 2017, 10:48 PM

The problem is related to overlays. I removed the overlays from the tours, now they are working again for the time being, but with a worse graphics.

Thanks for identifying the issue, whilst disabling the overlays has made the Items tutorial work, the Statements tutorial points to some elements further down the page (3rd box) and the page does not jump to that section any more meaning the tutorial appears to break (you have to know where to look for the box to find it).

You not be able to see this fault if you have a high resolution screen

Any ideas how the overlay part could be fixed?

thiemowmde closed this task as Resolved.Nov 13 2017, 11:38 AM
thiemowmde claimed this task.
thiemowmde triaged this task as Normal priority.
thiemowmde added a project: patch-welcome.
thiemowmde added a subscriber: thiemowmde.

I tried to understand the mentioned issue, but could not reproduce it. The original issue is fixed. If there is something else wrong with the tours, please open a new ticket. Thanks.