Page MenuHomePhabricator

"Related changes" can't work at zhwiki
Closed, ResolvedPublic

Description

On zhwiki "Related changes" ([[Special:RecentChangesLinked/xxx]]) can't work, but [[Special:RecentChangesLinked?target=xxx]]" can work.

Event Timeline

Shizhao created this task.Oct 16 2017, 1:47 PM
Restricted Application added subscribers: Cosine02, Aklapper. · View Herald TranscriptOct 16 2017, 1:47 PM
Shizhao updated the task description. (Show Details)Oct 16 2017, 1:53 PM

on [[Special:参数设置#mw-prefsection-rc]] check "Hide the improved version of Recent Changes", Related changes can work

Xiplus added a subscriber: Xiplus.Oct 16 2017, 3:20 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptOct 16 2017, 3:24 PM

If set RC filter as default, Related changes can't work

Xiplus added a comment.EditedOct 16 2017, 3:43 PM

I save a filter, filter setting is show both humon's and bot's edit, get "No active filters. All contributions are shown."(rcfilters-empty-filter) below the (rcfilters-activefilters) and set it as a default (rcfilters-savedqueries-setdefault), then visit https://zh.wikipedia.org/wiki/Special:%E9%93%BE%E5%87%BA%E6%9B%B4%E6%94%B9/%E6%9D%B1%E6%A3%AE%E7%B6%9C%E5%90%88%E5%8F%B0 , redirect to https://zh.wikipedia.org/w/index.php?title=Special:%E9%93%BE%E5%87%BA%E6%9B%B4%E6%94%B9&urlversion=2&limit=50&days=7 and get "No changes during the given period match these criteria." (recentchanges-noresult)

Remove filter as default (rcfilters-savedqueries-unsetdefault), filter setting is only show humon's edit (rcfilters-filter-humans-label), visit same url, redirect to https://zh.wikipedia.org/wiki/Special:%E9%93%BE%E5%87%BA%E6%9B%B4%E6%94%B9/%E6%9D%B1%E6%A3%AE%E7%B6%9C%E5%90%88%E5%8F%B0 , Related changes works.

@Etonkovidova can you please check this? Is Related Changes broken?

All wmf wiki sites have this problem

Liuxinyu970226 added a comment.EditedOct 18 2017, 8:24 AM

My guess is this can be happened with enabling gadgets? By restoring default settings both methods are work for me.


Johan added a subscriber: Johan.Oct 19 2017, 3:57 PM

(As this has been marked with user-notice: Is this a problem beyond zhwiki? Problems that are only relevant for one or two wikis probably shouldn't go into a global newsletter, unless the wikis are Commons or Wikidata which other wikis depend on, for the simple reason that it's easier to reach out to the users of that wiki in other ways.)

(As this has been marked with user-notice: Is this a problem beyond zhwiki?

All wmf wiki

Johan added a comment.Oct 20 2017, 1:13 PM

My guess is this can be happened with enabling gadgets? By restoring default settings both methods are work for me.

Do we have any idea of which gadget(s) could be the culprits in that case? Anything that could be more common on zhwiki? I've tried to enable gadgets without managing to reproduce the problem.

@Catrope, did you figure out whether this is something we need to put on the Q2 board or not?

@Catrope, did you figure out whether this is something we need to put on the Q2 board or not?

per this comment

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptOct 23 2017, 1:22 AM

Re-checked per the comment and confirmed that the link is working, i.e. shows the results on RelatedChanges

https://zh.wikipedia.org/w/index.php?title=Special:%E9%93%BE%E5%87%BA%E6%9B%B4%E6%94%B9/%E6%9D%B1%E6%A3%AE%E7%B6%9C%E5%90%88%E5%8F%B0 or [[Special:链出更改/東森綜合台]] works for me (as logged in and logged out)

Re-checking the steps per @A2093064 comment - most likely the problem is that 'Save filter' does not save all filter settings - e.g. it does not save selected number of days, number of changes to display and 'Page name' also cannot be saved. So, when default filters displayed on Special:链出更改/東森綜合台 are saved, and then the saved as a default filter is invoked, the Page name won't be saved as a part of the filter.

The steps:

  1. Go to Special:链出更改/東森綜合台 page
  2. The page displays Human(not bot), 'Page edits`, Page creations, Logged actions and Show last 50 changes, 7 days (which are default, but other values can be set as default by user in Preferences - RC). The Page name text box will have 東森綜合台
  3. Save this set as default filter.
  4. Navigate to a different page and enter in the Search box Special:链出更改/東森綜合台 to return to RelatedChanges.
  5. Related changes page will display your default filter which is Human(not bot), 'Page edits`, Page creations, Logged actions and Show last 50 changes, 7 days . The Page name text box will be empty. 東森綜合台 is not saved as a part of the default filter. No results will be displayed.

@Etonkovidova

The steps:

  1. Go to Special:链出更改/東森綜合台 page
  2. The page displays Human(not bot), 'Page edits`, Page creations, Logged actions and Show last 50 changes, 7 days (which are default, but other values can be set as default by user in Preferences - RC). The Page name text box will have 東森綜合台
  3. Save this set as default filter.
  4. Navigate to a different page and enter in the Search box Special:链出更改/東森綜合台 to return to RelatedChanges.
  5. Related changes page will display your default filter which is Human(not bot), 'Page edits`, Page creations, Logged actions and Show last 50 changes, 7 days . The Page name text box will be empty. 東森綜合台 is not saved as a part of the default filter. No results will be displayed.

But why my browser shows it as-is following steps above? (Chrome 55.0.2883.87 on Windows 8.1)

Etonkovidova added a comment.EditedOct 24 2017, 4:10 AM

@Liuxinyu970226
When you navigated away from Special:链出更改/東森綜合台 with Saved default filter (in the step 4), did you return to the page (in the step 5) via the browser back button? If you used the browser back button, your default saved filter will be displayed with 東森綜合台 in the Page name text box.

@Liuxinyu970226
When you navigated away from Special:链出更改/東森綜合台 with Saved default filter (in the step 4), did you return to the page (in the step 5) via the browser back button? If you used the browser back button, your default saved filter will be displayed with 東森綜合台 in the Page name text box.

Ah, I missed a condition: default filter

OK. Thanks Elena. I see now what the issue is: on Related Changes, Saved Filters do not include the page name that is the basis for the "Related" search.

Do I understand the issue properly? If so, the question we need to answer now is whether the user's expectation that the page should be part of the Saved Filter is something we want to act on. I can see how it might be useful for some users, but overall it seems overly narrow to me. It must be the case, for example, that some users would want to apply the a consistent filter set to numerous pages. So they would need a separate saved filter for each page. And, as a real capper to this line of thinking, remember that Saved Filters are shared between Recent Changes and Related Changes. So all those filters would simply be useless duplicates of one another on RC page (assuming we could make RC page ignore the pagename parameter).

For these reasons, my sense is that we should respectfully decline the request. Other opinions?

@SBisson, thinking about this more (with input from colleagues), I can see how it could be useful. But we need to know: is it easy or hard?

@SBisson, thinking about this more (with input from colleagues), I can see how it could be useful. But we need to know: is it easy or hard?

The two new filters on Related Changes are different from all other filters and require special treatment on way or another. I don't think any of the 2 options presented here is significantly more work than the other. They both challenges our previous categorization of the filters and need some rethinking.

In terms of product, I do see how including the target page in saved filters AND sharing the saved filters between Recent changes and Related changes can be problematic. It would lead to potentially many filters visible on Recent changes that wouldn't work as expected. That's really what I would like to get clarity on.

The bug as originally reported should be mostly fixed this week, by T181100#3790037 and Stephane's recent changes to RCL.

Let's not talk too much about whether the page name should be part of the saved query (I think it shouldn't be) until we figure out what the actually broken things are (e.g. a saved query wiping out the page name completely) and whether they are fixed.

Shizhao closed this task as Resolved.Dec 6 2017, 7:42 AM
Shizhao claimed this task.

The bug as originally reported should be mostly fixed this week, by T181100#3790037 and Stephane's recent changes to RCL.

per @Catrope , fixed on zhwiki.

Shizhao moved this task from Backlog to Closed on the Chinese-Sites board.Dec 7 2017, 1:19 AM