Page MenuHomePhabricator

Other review tools has inconsistent border behavior
Closed, ResolvedPublic

Description

Border for "Other review tools" link shows and disappears depending on previous state upon page load/reload.

  • If previous state was collapsed, border will not be displayed around "Other review tools" and whole panel in general when tools are opened.
  • If previous state was opened, border will be displayed in both collapsed and opened state.

The inconsistency was introduced as part of patch for T177117: Page elements still jumping around and blinking on RC page and Watchlist.

Here is a gif that tries to illustrate what happens, but due to longish reload times, I have cut out some of the frames, which can make it look strange.

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 17 2017, 2:51 PM

The issue is in production (wmf.4) now - testwiki and cawiki.

Unless I remember wrong, the design dictated having a border when the box is open -- but having no border on the toggle button itself, so that explains why the border disappears when minimizing.

Does this produce jumpiness? It's hard to tell from the gif because of the toggle up/down effect.

@Pginer-WMF what should we do here? Should we add a border to the button when it is collapsed, or leave it as-is? You can test it in production and beta to see what is going on?

The issue is in production (wmf.4) now - testwiki and cawiki.

@Mooeypoo, since this in now in production, you can see first hand more easily what's really happening.

The behavior is not according to design you're talking about in the above comment. I have tried to explain what's happening, but apparently fell short. In gif, that's in description, I am reloading the page every time mouse leaves the frame. My intention was to make gif shorter because of longish reload times and cut much of the frames, but that caused weird look that is confusing you. I failed in intention to save your time.

Please try the following:

  1. Open the box of "Other review tools"
  2. Reload the page
  3. Collapse the box
  4. Reload the page

Hopefully, after that you will realize where the issue lies. The border is either appearing for both collapsed and opened box, or not appearing for both collapsed and opened box. Existence of border depends of previous state (collapsed or open) when page is (re)loaded.

I see it now, sorry, I was confused.

Let me see what's going on there.

Change 385222 had a related patch set uploaded (by Mooeypoo; owner: Mooeypoo):
[mediawiki/core@master] RCFilters: Actually toggle the collapsed class for toplinks

https://gerrit.wikimedia.org/r/385222

Change 385222 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Actually toggle the collapsed class for toplinks

https://gerrit.wikimedia.org/r/385222

Checked the fix in betalabs.

Etonkovidova closed this task as Resolved.Oct 19 2017, 11:25 PM