Page MenuHomePhabricator

Outdated Plugins in Wikimedia Blog theme (wikimedia-v2)
Open, Needs TriagePublic

Description

Hey folks,

I got this message from WordPress last night. Is this something we can take on? Thank you!


Howdy!

We noticed that one or more of your themes are using an outdated version of a shared plugin. We highly recommend for you to upgrade your plugins to the most recent version available. We want to give you the best VIP experience possible and updating old plugins allows you to have bug fixes and performance improvements on your site.

These are the themes and plugins we've identified:

Theme: wikimedia-v2

  • Outdated: fieldmanager Replace with: fieldmanager-1.1

Please install, activate and test the most recent version of these.

You can find the current list of VIP plugins here https://vip-svn.wordpress.com/plugins/ - the one with the highest version number is the one to use.

The plugins identified here are all activated through your theme code, rather than through the WP admin panel. To update the plugin version you must specify the plugin folder (in the case of shared plugins, this will always be “plugins”) and the version number. So for example updating the co-authors-plus plugin would require changing this:

wpcom_vip_load_plugin( 'co-authors-plus' );

To this:

wpcom_vip_load_plugin( 'co-authors-plus', 'plugins', '3.2' );

Let us know if you need any help or have any questions installing the latest version of the plugin in your theme!

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 17 2017, 3:25 PM

@EdErhart-WMF Yes, we can take it on. But I'd put it on low priority and target for the next couple of weeks.

EdErhart-WMF updated the task description. (Show Details)Oct 26 2017, 9:57 PM

@Volker_E - sounds good! Do we have a target date for this? Thank you very much for your help here.