Page MenuHomePhabricator

Please add a log for new page creations
Closed, DuplicatePublic

Description

Page creation logs have been useful in the past for non-admins trying to determine who uploaded deleted files and created deleted articles and other pages, for cross-referencing while doing New Page Patrol and processing Help Desk requests and OTRS tickets. Now, those logs are missing, and speedily deleted items are leaving no trace of their creators' identities. Please put those logs back, on all wikis.

Related Objects

Event Timeline

Jeff_G created this task.Oct 18 2017, 3:06 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 18 2017, 3:06 PM
Jeff_G updated the task description. (Show Details)Oct 18 2017, 3:07 PM
Jeff_G updated the task description. (Show Details)

Umm, which page creation log specificly do you mean? Can you give a url to where the log used to be?

In the upload case, we of course have special:log/upload. But in the general case, I believe we only have Special:NewPages, which only lasts for 30 days and entries get removed after deletion.

Are you sure that this log actually existed previously?

For the start, where have these logs been located usually? Steps to reproduce are welcome in bug reports.

Jeff_G added a comment.EditedOct 25 2017, 2:43 PM

Sorry, I was confused. I meant that page creation logs would be helpful for the reasons detailed above.

Bawolff renamed this task from Page creation logs missing to Please add a log for new page creations.Oct 25 2017, 3:00 PM

Currently this information is avaliable to people with deletedhistory rights (By going to Special:Undelete or the "Show X deleted revisions" link). I would suggest that instead of adding this feature, we just give deletedhistory right more broadly (Assuming you have consent of the wiki communities involved)

Proposing to decline as per last comment? (But up to the English-Wikipedia-New-Pages-Patrol folks.)

Ammarpad closed this task as Invalid.Mar 17 2019, 6:31 PM
Ammarpad added a subscriber: Ammarpad.