Page MenuHomePhabricator

Include wikibase-data-model npm package as a submodule of Wikibase git repo
Closed, ResolvedPublic

Description

The repo of the npm package should be a submodule in Wikibase git repo.
Wikibase should define ResourceLoader modules including files from the npm package, that Wikibase uses.

Details

Related Gerrit Patches:

Event Timeline

WMDE-leszek renamed this task from T178576 Include wikibase-datamodel npm package as a submodule of Wikibase git repo to T178576 Include wikibase-data-model npm package as a submodule of Wikibase git repo.Oct 19 2017, 2:29 PM
WMDE-leszek renamed this task from T178576 Include wikibase-data-model npm package as a submodule of Wikibase git repo to Include wikibase-data-model npm package as a submodule of Wikibase git repo.Oct 24 2017, 12:47 PM

Change 385409 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Install wikibase data model js lib as a git submodule, not as a composer dependency

https://gerrit.wikimedia.org/r/385409

WMDE-leszek closed this task as Resolved.Nov 2 2017, 1:33 PM
WMDE-leszek removed a project: Patch-For-Review.