Page MenuHomePhabricator

Include wikibase-api npm package as a submodule of Wikibase git repo
Closed, ResolvedPublic

Description

The repo of the npm package should be a submodule in Wikibase git repo.
Wikibase should define ResourceLoader modules including files from the npm package, that Wikibase uses.

Details

Related Gerrit Patches:

Event Timeline

Change 385199 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Install wikibase js api as a git submodule, not as a composer dependency

https://gerrit.wikimedia.org/r/385199

WMDE-leszek closed this task as Resolved.Nov 2 2017, 12:14 PM
WMDE-leszek moved this task from Review to Done on the Wikidata-Former-Sprint-Board board.