Page MenuHomePhabricator

Pixelated images in PDF rendering.
Closed, ResolvedPublic

Description

The resolution of the images included is pixelated and the images seem inflated, especially noticeable for smaller images like SVG icons etc.


This is probably a dpi mismatch (SVGs shouldn't have a limit on how large they can be rendered by design).

PDF from: https://en.wikipedia.org/wiki/en:Template:Tsuen%20Wan%20Line%20RDT
Reported at: https://www.mediawiki.org/wiki/Topic:U08at90ido2loj5q

Reproduction criteria

  • for a number of browsers and operating systems, test whether images appear pixelated using:
    • the browser print
    • download as PDF (Electron)
  • if time, perform exploratory testing to identify other articles with the bug
  • provide screenshots of each instance the bug appears

Event Timeline

TheDJ created this task.Oct 20 2017, 9:22 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 20 2017, 9:22 AM
Jdlrobson moved this task from Later to Watching on the Readers-Web-Backlog (Tracking) board.
ovasileva triaged this task as Medium priority.Dec 1 2017, 2:23 PM
ovasileva moved this task from Triage to Tracking on the Proton board.Dec 1 2017, 3:01 PM
ovasileva updated the task description. (Show Details)
ovasileva updated the task description. (Show Details)Dec 1 2017, 3:16 PM
Jc86035 updated the task description. (Show Details)Dec 1 2017, 3:19 PM

This seems reproducible across most browsers. Download as PDF on Chrome looked the most 'crisp' to me.

Mac 10 Chrome 62
Browser PrintDownload as PDF
Mac 11 Firefox 57
Mac 10 Safari 11
Windows 10 Edge 14
Windows 10 Chrome 62
Jdlrobson added a subscriber: Jdlrobson.

@ABorbaWMF could you take a look and see if the fix for T181138 also fixed this?

Took a quick look at this one. I am seeing roughly the same results. The images are a bit fuzzy.

PrintPDF

Did you check staging or beta cluster? The change is NOT live on production yet but will be later today.

Sorry for not making that clear :(

@Jdlrobson, ok that makes sense. @ovasileva and I thought the change had already pushed. I'll take another look later today.

That was my bad. For future reference - when does the train go out on thursday roughly?

@pmiazga - is there any way we can test this in Chromium?

ABorbaWMF closed this task as Resolved.May 31 2018, 10:39 PM

Looks good now on production on Chrome. Also tested on Beta with a few articles. Looks good

Looks good now on production on Chrome. Also tested on Beta with a few articles. Looks good

Hi @ABorbaWMF - interesting - this should still be an issue in production (which still has the Electron renderer). The Chromium renderer is only available on the beta cluster.

Jc86035 added a comment.EditedJun 1 2018, 10:17 AM

The image – if from Chromium – seems a bit problematic. One of the images is still clearly incorrectly aligned, the one in the Lai King row. This is worrying, because it might mean that the new software is incorrectly rounding the image widths. (The gap between that image and the other images in the row is an empty table cell with a set width.) Several of the images (the corner pieces for the 45° tracks) did not render at all, and many of the ones which did render appear to be quite distorted (the circles should be round, and the curves in the second-last row should be smooth). I can't tell why.

Obviously, these are not problems for most images, but it would be nice if they could be fixed (if they're problems with the renderer). These diagrams are used on more than ten thousand pages across WMF wikis.

In addition, the colours being stripped makes the interchange boxes useless, and the background colour being stripped makes the fade overlays look incorrect because IIRC they are supposed to match #f9f9f9 (the old MediaWiki table background colour). However, this is more of a problem with whatever CSS is being used.