Page MenuHomePhabricator

Special:APIFeatureUsage is a 404 error on urwiki
Closed, ResolvedPublic

Description

API feature usage on Urdu Wikipedia isn't working.

-->urwiki:
https://ur.wikipedia.org/wiki/Special:ApiFeatureUsage

-->enwiki
https://en.wikipedia.org/wiki/Special:ApiFeatureUsage

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 21 2017, 2:31 AM
Liuxinyu970226 renamed this task from API feature usaga on urwiki to API feature usage isn't showing on urwiki.Oct 21 2017, 2:59 AM
Liuxinyu970226 updated the task description. (Show Details)
Liuxinyu970226 added a subscriber: Liuxinyu970226.EditedOct 21 2017, 3:01 AM

One attention: This is affecting all Urdu Wikis (e.g. Urdu Wiktionary isn't working too), but not affect RTL (Arabic and Hebrew Wikipedias are working well)

MuhammadShuaib triaged this task as High priority.Oct 21 2017, 4:07 AM

Change 385530 merged by jenkins-bot:
[mediawiki/extensions/ApiFeatureUsage@master] Fix broken special page alias for Urdu

https://gerrit.wikimedia.org/r/385530

Jdforrester-WMF closed this task as Resolved.Oct 23 2017, 5:55 PM
Jdforrester-WMF assigned this task to MuhammadShuaib.

Going to https://ur.wikipedia.org/wiki/Special:ApiFeatureUsage your browser's "Developer Tools" will shown in the Network tab that this is a 301 redirect to https://ur.wikipedia.org/wiki/خاص:اےپی_آئی__خصوصیات_کا_استعمال
And that page is a 301 again to
https://ur.wikipedia.org/wiki/خاص:اےپی_آئی_خصوصیات_کا_استعمال (one less underscore here).
And that page is a 404 error (file not found).

The Gerrit patch merged above changed the alias to خاص:اے_پی_آئی_خصوصیات_کا_استعمال

See the difference (additional underscore) between اے_پیand ےپی between the translation and the 404 page.

That might be related or unrelated to the problem here.

Aklapper renamed this task from API feature usage isn't showing on urwiki to Special:APIFeatureUsage is a 404 error on urwiki.Oct 29 2017, 12:54 PM
Aklapper removed a project: Patch-For-Review.
Anomie closed this task as Resolved.Oct 30 2017, 2:42 PM
Anomie added a subscriber: Anomie.

Due to T179156, 1.31.0-wmf.5 wasn't deployed to group 2 wikis (including urwiki) as scheduled. The problem does seem to be resolved in that version, as you can see by visiting https://ur.wiktionary.org/wiki/Special:ApiFeatureUsage.

Feel free to reopen if the issue is not fixed once 1.31.0-wmf.5 or later is deployed to urwiki; you can check https://ur.wikipedia.org/wiki/Special:Version to see the version currently running.