Page MenuHomePhabricator

Export to code option
Closed, DeclinedPublic

Description

Ok, I was translating the article on :w:en:Michael D. Coe to my userspace on plwiki. I translated most of it, avoiding clicking on any templates, since in the past it broke the CT (bug reported numerous times, no response so far). Tonight I returned to the translation, but apparently the source article was changed in the meantime. And guess what, the entire page is greyed-out. I can see the orange memo informing me about the article change, but can't close it. Can't publish the translation, edit it, nothing. It looks precisely the same as in the case of "Infobox breaks CT".

So I thought there must be a better way. Since the translation is apparently being saved, and since the content is apparently there (inaccessible, but it is there), how about adding an option to the article list (Special:ContentTranslation) to export the translated article to code (either to user draft space or to a txt file, doesn't really matter). I want my hard work back and apparently once the CT greys out, it's impossible to publish anything, which means I would have to basically start over. However, perhaps there is a way to recover the translated text from without the CT engine itself.

This way we could - as a last resort - bypass many bugs that have been troubling the CT engine, including the "clicking Infobox breaks the CT", "http 400" and a plethora of others. The article text would be pulled directly from the database, regardless of the CT engine itself. Is it doable?

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 21 2017, 10:41 PM

BTW, originally reported here, but since there was no response for the last two months, I took the liberty to report it here.

Amire80 closed this task as Declined.Oct 27 2017, 5:56 AM
Amire80 added a subscriber: Amire80.

The problem is that the component that would allow such saving is the same component that causes the problem. Fixing it, as part of the Visual editor integration, has been our main focus for the last few months, but it will take some more time.

There is also the scenario of some editors wanting to to the translation in source code, and that will be addressed more or less at the same time when we integrate Visual editor component and its source editing function.

Halibutt added a comment.EditedOct 31 2017, 11:23 PM

it will take some more time.

Thanks for the info @Amire80. Is there a chance I'll be able to salvage my work, or is it lost forever and I should start over?