Page MenuHomePhabricator

Images shown in the link tool are very short and wide at cswiki
Closed, ResolvedPublic1 Estimated Story Points

Description

Reported by User:Awewewe at https://www.mediawiki.org/wiki/Topic:U0f0e2q1pncgjbfj

See https://commons.wikimedia.org/wiki/File:Links_problem.png for a screenshot. The link images are very wide and short. The aspect ratio is about 5:2, and I think it's meant to be 16:9 (or thereabouts).

Event Timeline

Restricted Application added a project: VisualEditor. · View Herald TranscriptOct 24 2017, 6:16 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Elitre added a subscriber: Elitre.Oct 24 2017, 6:19 PM
Deskana triaged this task as Medium priority.Oct 24 2017, 6:36 PM
Deskana moved this task from To Triage to TR1: Releases on the VisualEditor board.
Deskana set the point value for this task to 1.
Deskana added a subscriber: Deskana.

How peculiar. It's even doing it for placeholder images. @matmarex Some kind of OOUI regression?

Deskana raised the priority of this task from Medium to Unbreak Now!.Oct 24 2017, 6:57 PM

This is happening everywhere. The screenshot below is from English Wikipedia.

Restricted Application added subscribers: Liuxinyu970226, Jay8g, TerraCodes. · View Herald TranscriptOct 24 2017, 6:57 PM
DLynch added a subscriber: DLynch.Oct 24 2017, 7:55 PM

I think this is further fallout from 8e31b2f27342f7fe3aa188412e719bf86249d08f.

Change 386286 had a related patch set uploaded (by DLynch; owner: DLynch):
[mediawiki/extensions/VisualEditor@master] MWInternalLinkContextItem: increase specificity to override OOUI changes

https://gerrit.wikimedia.org/r/386286

To confirm, I did some testing of OOUI releases, and that icons commit does seem to have been the cause after all. The patch fixes it by increasing the specificity of our overrides so they (particularly the height) apply again.

Change 386286 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] MWInternalLinkContextItem: increase specificity to override OOUI changes

https://gerrit.wikimedia.org/r/386286

Change 386308 had a related patch set uploaded (by Jforrester; owner: DLynch):
[mediawiki/extensions/VisualEditor@wmf/1.31.0-wmf.5] MWInternalLinkContextItem: increase specificity to override OOUI changes

https://gerrit.wikimedia.org/r/386308

Change 386309 had a related patch set uploaded (by Jforrester; owner: DLynch):
[mediawiki/extensions/VisualEditor@wmf/1.31.0-wmf.4] MWInternalLinkContextItem: increase specificity to override OOUI changes

https://gerrit.wikimedia.org/r/386309

Scheduled for deployment during the European mid-day SWAT.

Change 386309 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@wmf/1.31.0-wmf.4] MWInternalLinkContextItem: increase specificity to override OOUI changes

https://gerrit.wikimedia.org/r/386309

Mentioned in SAL (#wikimedia-operations) [2017-10-25T14:11:13Z] <matt_flaschen> 'Deployed T178933: MWInternalLinkContextItem: increase specificity to override OOUI changes'

Deskana closed this task as Resolved.Oct 25 2017, 2:17 PM
Deskana assigned this task to DLynch.

Deployed.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptOct 25 2017, 2:17 PM
matmarex updated the task description. (Show Details)Oct 25 2017, 3:18 PM

Change 386308 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@wmf/1.31.0-wmf.5] MWInternalLinkContextItem: increase specificity to override OOUI changes

https://gerrit.wikimedia.org/r/386308

Mentioned in SAL (#wikimedia-operations) [2017-10-25T23:48:15Z] <legoktm@tin> Synchronized php-1.31.0-wmf.5/extensions/VisualEditor/modules/ve-mw/ui/styles/contextitems/ve.ui.MWInternalLinkContextItem.css: MWInternalLinkContextItem: increase specificity to override OOUI changes - T178933 (duration: 00m 50s)