Page MenuHomePhabricator

Add case-insensitive title match capability for Wikidata search
Closed, ResolvedPublic

Description

For wikidata, we need to match ID (like Q42) in case-insensitive manner (q42 should match) while still keeping the exact match. As far as I can see, current fields do not provide a good way to do it. Maybe we should add a field for title? Or use some special syntax? T179045 presents workaround for the problem (uppercasing search string) but this is a hack, not a proper long-term solution.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 26 2017, 5:13 PM
Aklapper renamed this task from Add case-insenstivie title match capability for Wikidata search to Add case-insensitive title match capability for Wikidata search.Oct 27 2017, 1:57 PM
Smalyshev edited projects, added Technical-Debt; removed Regression.Nov 7 2017, 7:52 AM
debt moved this task from needs triage to Up Next on the Discovery-Search board.Nov 30 2017, 6:18 PM
Lydia_Pintscher moved this task from incoming to monitoring on the Wikidata board.Dec 18 2017, 2:57 PM
Smalyshev moved this task from Backlog to Next on the User-Smalyshev board.May 7 2018, 5:37 PM

I wonder if title.prefix_asciifolding wouldn't work for this use case? @dcausse, what do you think?
Asciifolding does a bit more than we need but I don't think it would do any harm in this use case...

@Smalyshev yes I'm pretty sure it'll work without annoyance. The only possible annoyance I could think about is because ℚ will be folded to Q but since it's not a prefix match it's probably not a big deal...

Sorry I misread your comment,
It should be title.near_match_asciifolding not title.prefix_asciifolding, the latter will allow finding Q423213 when typing q42 so that is not what the task description says.

because ℚ will be folded to Q

Don't think this is a huge deal... If it proves to be, then we can reopen.

title.near_match_asciifolding not title.prefix_asciifolding

Ah, sure. But then I think there's nothing more left to do here.

Smalyshev closed this task as Resolved.May 11 2018, 3:52 AM
Smalyshev claimed this task.