Page MenuHomePhabricator

Hovercard shows up when pointer is on ref link; displays text of the very page you're on
Closed, DeclinedPublic

Description

Schermata 2017-10-26 alle 16.56.50.png (320×1 px, 193 KB)

You can probably ignore the navpopup there, it comes from my global pref page at Meta.
However, I dunno that I should see a hovercard when hovering on that [2] ref. It contains the article's lede.

Replication steps

Event Timeline

In general, providing steps to reproduce is welcome. :) This is about https://en.wikipedia.org/wiki/English_possessive#Nouns_and_noun_phrases
Could not reproduce there.

Aklapper renamed this task from Hovercard shows up when pointer is on ref link? to Hovercard shows up when pointer is on ref link; displays text of the very page you're on.Oct 26 2017, 10:05 PM

Which steps? There's nothing in particular other than having PP enabled and hovering on a ref link.
It happens to me in any article (which is why I didn't bother pointing out to one in particular), any language, and in the few browsers I tried so far (Safari isn't uptodate, but Chrome on Win 10 is - 62.0.3202.75 (Official Build) (64-bit)). The hovercard will include an image when there's one in the article: it's basically /the/ hovercard for that article, it just pops up where one wouldn't expect it.
It could be that you don't also have NavPopups enabled via your global.js page, maybe that's what makes a difference.

Which steps? [...] It happens to me in any article

That wasn't clear before. Thanks.

ovasileva triaged this task as Medium priority.Oct 30 2017, 3:35 PM
ovasileva added subscribers: ABorbaWMF, ovasileva.

I still can't reproduce from my end. @ABorbaWMF - could you take a look on the browsers/platform suggested in https://phabricator.wikimedia.org/T179097#3714940? @Elitre - have you tried the results when disabling navigation popups? We're only taking care of the pages where nav popups are enabled via the gadgets menu versus global.js pages.

Jdlrobson added a subscriber: Jdlrobson.

@Elitre I cannot reproduce either (I've added some steps in the task but please flesh out with moe information if I've missed something)
We will need more information before being able to do anything about this.

@ovasileva, I took a look at a few browsers, but I cannot reproduce this one. I tried on Mac with Chrome and Safari and on Windows with Chrome and IE. Once the reference tooltip is disabled I see nothing when hovering over a reference link.

@Elitre, as far as I can tell the only difference between your setup and mine is the "global pref page at Meta." My guess is that this is causing the issue. Can you tell us more about that navpopup? Thanks

Jdlrobson changed the task status from Open to Stalled.Oct 31 2017, 5:05 PM

@Jdlrobson - stalled on reproduction? Perhaps we should move back to needs analysis?

@Elitre, as far as I can tell the only difference between your setup and mine is the "global pref page at Meta." My guess is that this is causing the issue. Can you tell us more about that navpopup? Thanks

Yes, this is also why Andre couldn't reproduce, it seems. If you have the NavPopups gadget enabled globally, it appears that both a navpopup and a hovercard will show up when hovering over the reference number.

I can confirm that with the following in my global.js on metawiki I can reproduce this issue easily:

mw.loader.load('https://en.wikipedia.org/w/index.php?title=MediaWiki:Gadget-popups.js&action=raw&ctype=text/javascript');
mw.loader.load('https://en.wikipedia.org/w/index.php?title=MediaWiki:Gadget-navpop.css&action=raw&ctype=text/css', 'text/css');

Given the updated message for interactions with navpopups in T178566: Mention global JS in NavPopups conflict message my suggestion would be to decline this, unless we think there's an easy fix.