Page MenuHomePhabricator

Puppet4: update hiera function call in openldap labs-acls.erb template
Closed, ResolvedPublic

Description

WARN -- : Failed build_catalog for future validation: OctocatalogDiff::Errors::CatalogError Catalog failed: Failed to retrieve catalog from https://puppetmaster2001.codfw.wmnet:8140/future/catalog/seaborgium.wikimedia.org: 500 {"message":"Server Error: Evaluation Error: Error while evaluating a Function Call, Failed to parse template openldap/labs-acls.erb:\n  Filepath: /usr/lib/ruby/vendor_ruby/puppet/parser/functions.rb\n  Line: 275\n  Detail: hiera() can only be called using the 4.x function API. See Scope#call_function\n at /etc/puppet/modules/openldap/manifests/init.pp:126:24 on node seaborgium.wikimedia.org","issue_kind":"RUNTIME_ERROR","stacktrace":["Warning: The 'stacktrace' property is deprecated and will be removed in a future version of Puppet. For security reasons, stacktraces are not returned with Puppet HTTP Error responses."]}

Event Timeline

Change 386897 had a related patch set uploaded (by Herron; owner: Herron):
[operations/puppet@production] puppet: update hiera function call in openldap labs-acls template

https://gerrit.wikimedia.org/r/386897

Change 386897 merged by Herron:
[operations/puppet@production] puppet: update hiera function call in openldap labs-acls template

https://gerrit.wikimedia.org/r/386897

herron renamed this task from Puppet4: Error while evaluating a Function Call, Failed to parse template openldap/labs-acls.erb:\n Filepath: /usr/lib/ruby/vendor_ruby/puppet/parser/functions.rb\n Line: 275\n Detail: hiera() can only be called using the 4.x function API. See Scope#call_function\n at /etc/puppet/modules/openldap/manifests/init.pp:126:24 to Puppet4: update hiera function call in openldap labs-acls.erb template.Oct 27 2017, 5:22 PM
herron closed this task as Resolved.
herron claimed this task.
herron removed a project: Patch-For-Review.