Page MenuHomePhabricator

Improve format of “Main page” across all article packs
Closed, InvalidPublic3 Story Points

Description

Finding from usability testing conducted in T167129:
Participants across both usability studies often used the ‘Main page’ as the entry point to access articles, they wanted to see a clearer ‘introductory’ text and high-level contents similar to the main page of the WikiMed pack.

Proposed solution:

Part A. Show a notification/message on the Main page of every article pack advising of its purpose

For the side-loading version of the Offline Library feature, we may insert a standard message into the Main page.

Approach 1: Dialog message
Approach 2: Dismissable 'card' over the Main page content
Approach 3: Non-dismissable message within Main page content (below title and description:
NOTE: It was decided to use Approach 3 both for simplicity of implementation and also as being more flexible if in future we create our own article packs with improved Main page formatting (that does not require this message).

==== Part B. Add a separate 'Main page' card in the feed for each article pack in the Offline Library.
This enables users to more easily access the "Main page" of article packs without needing to navigate to a pack's details screen.

NOTE: This part of the ticket is a a dupe of T174157

Details

Related Gerrit Patches:

Event Timeline

NHarateh_WMF set the point value for this task to 3.Nov 6 2017, 5:21 PM
RHo updated the task description. (Show Details)Nov 6 2017, 6:51 PM
RHo updated the task description. (Show Details)

Change 389997 had a related patch set uploaded (by Dbrant; owner: Dbrant):
[apps/android/wikipedia@master] Inject a hint message into Main Pages of offline article packs.

https://gerrit.wikimedia.org/r/389997

Change 389997 merged by jenkins-bot:
[apps/android/wikipedia@master] Inject a hint message into Main Pages of offline article packs.

https://gerrit.wikimedia.org/r/389997

Works for me on Nexus 5 (6.01), Wikipedia 2.7.224-alpha-2018-01-17 when viewing the WikiMed article pack's main page:

ABorbaWMF added a subscriber: ABorbaWMF.

Testing on v2.7.224-alpha-2018-01-26

I am seeing different results on my two test devices. On the Pixel (android 8.1.0) I am seeing the notification. On the Nexus 4 (android 5.1.1) I am seeing an entirely different page:

PixelNexus 4
Dbrant closed this task as Invalid.Oct 16 2018, 3:44 PM