Page MenuHomePhabricator

Magic word "PAGESINCATEGORY" does not return value on bn.wikipedia and bn.wikisource
Open, Needs TriagePublic

Description

Magic word "PAGESINCATEGORY" is not returning the value without additional parameters.

Works only if i supply additional parameter e.g. all/files/pages etc.

{{PAGESINCATEGORY:cat name|all/files/pages}} works but {{PAGESINCATEGORY:cat name}} doesn't, return 0. try {{PAGESINCATEGORY:ভালো নিবন্ধ}} on bnwiki.

It supposed to be working without any additional (all/pages/files etc) parameters. see other wikis.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 29 2017, 9:01 PM
jayantanth updated the task description. (Show Details)Oct 29 2017, 9:02 PM

Works only if you supply additional parameter e.g. all/files/pages etc.

{{PAGESINCATEGORY:cat name|all/files/pages}} works but {{PAGESINCATEGORY:cat name}} doesn't, return 0.

jayantanth closed this task as Resolved.Oct 29 2017, 10:00 PM
jayantanth claimed this task.
Aftabuzzaman reopened this task as Open.Oct 29 2017, 10:07 PM

I'm reopening this task. "PAGESINCATEGORY" supposed to be working without any additional parameters (see other wikis). Why this isn't working for bnwiki?

Aftabuzzaman removed jayantanth as the assignee of this task.Oct 29 2017, 10:11 PM
Aftabuzzaman updated the task description. (Show Details)
Aklapper renamed this task from Magic word "PAGESINCATEGORY" is not return the value and BNWP and BNWS to Magic word "PAGESINCATEGORY" does not return value on bn.wikipedia and bn.wikisource.Oct 30 2017, 10:05 AM

Please always provide direct links that allow reproducing.
So this seems to be about https://bn.wikipedia.org/wiki/টেমপ্লেট:বিষয়শ্রেণীতেমোটনিবন্ধ and examples would be

{{PAGESINCATEGORY}}
{{PAGESINCATEGORY:ভালো নিবন্ধ}}
{{PAGESINCATEGORY|ভালো নিবন্ধ}}
{{PAGESINCATEGORY:ভালো নিবন্ধ|all}}
{{PAGESINCATEGORY|ভালো নিবন্ধ|all}}
{{PAGESINCATEGORY:ভালো নিবন্ধ|files}}
{{PAGESINCATEGORY:ভালো নিবন্ধ|pages}}

Hello @Aklapper, This task is about Magic word "PAGESINCATEGORY", not about Template:PAGESINCATEGORY that uses Magic word "PAGESINCATEGORY". So, i'm not including template here.

For reproducing: go to any category page, copy that category name & paste inside {{PAGESINCATEGORY: ...category name....}}. Here i'm using this category which have 71 articles:

{{PAGESINCATEGORY:ভালো নিবন্ধ}} gives 0 (not correct result, but in other wikis it gives 71 which is correct)

{{PAGESINCATEGORY:ভালো নিবন্ধ|all}} gives correct result
{{PAGESINCATEGORY:ভালো নিবন্ধ|files}} gives correct result
{{PAGESINCATEGORY:ভালো নিবন্ধ|pages}} gives correct result