Page MenuHomePhabricator

mw-collapsible elements should be configurable (e.g. to disable the fading effects)
Closed, ResolvedPublic

Description

I simply want to configure the .mw-collapsible elements to remove the annoying (to me) fading effects, by configuring the toggling callback with an instantHide option.
Despite 516f8cad49e8, passing the option is just not possible currently.

Refs the resources: mediawiki/page/ready.jsjquery/jquery.makeCollapsible.js

Event Timeline

Od1n created this task.Nov 2 2017, 8:15 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 2 2017, 8:15 PM
Od1n updated the task description. (Show Details)Nov 2 2017, 8:17 PM

Hi @Od1n, "should be configurable" is too vague and does not allow understanding the underlying problem you would like to see solved.
Maybe something like "Allow disabling fading effect on .mw-collapsible elements"? You can edit the task summary by clicking Edit Task. Thanks!

Od1n renamed this task from mw-collapsible elements should be configurable to mw-collapsible elements should be configurable (e.g. to disable the fading effects).Nov 3 2017, 8:47 PM
Od1n added a comment.Nov 3 2017, 8:54 PM

The issue is mainly about configurability: the code implements objects to manage options, yet the end-user cannot reach these options.

The fading effect on toggling is only an example (but maybe there are not many examples). I picked this one because it is relevant, and it even has a shiny instantHide option awaiting to be used… but it cannot be reached.

TheDJ closed this task as Resolved.May 22 2018, 4:37 PM
TheDJ claimed this task.
TheDJ added a subscriber: TheDJ.

Animations have now been removed.